3.2.4 upgrade fails to start on freebsd5.4

Discussion in 'General' started by joe, Oct 27, 2007.

  1. joe

    joe Member

    I'm having trouble getting a working 3.1.1 upgrade to 3.2.4 to work on freebsd5.4.

    The install script initially reported errors finding several files located under /usr/compat/linux which I created symbolic links to under /usr/local/lib and resolved those errors, but the server still fails to start. Full debug logging doesn't give any meaning result, nor is there anything in var/log/messages.

    What info do you need to help diagnose this?
  2. joe

    joe Member

    Hello, Support?
  3. mistwang

    mistwang LiteSpeed Staff

    We are looking at the issue, are you using "i386-freebsd" build? i386-freebsd6 package will not work with freebsd5.4
  4. joe

    joe Member

    I believe I choose the freebsd 4/5 version when I down loaded it, but from the file name, yes its called i386-freebsd". When I double check here's the md5 hash of the file I down loaded: 9c897c22f1b16e052f9e601fb12104b7

    Thanks for the help...
  5. mistwang

    mistwang LiteSpeed Staff

    OK. the i386-freebsd package has been updated to address the problem. The binary referenced libgcc_s.so due to a problem in our gcc 3.4.6 based new cross compiler for FreeBSD platform. Fixed.
  6. joe

    joe Member

    Ok! Much better thank you. So far it seems to behave normally again.

    If anything else pops-up I'll report it.

    Again thanks.

Share This Page