4.0.18 gives error

Discussion in 'Bug Reports' started by jeckdenial, Jan 4, 2011.

  1. jeckdenial

    jeckdenial New Member

    Hello there

    I am running on Current Version: 4.0.18 of Litespeed.

    But getting Error atleast 4 a day

    web server with pid=10139 received unexpected signal=15, no core file is created. A new instance of web server will be started automatically!

    Please guide me wht i should do to avoid this?

    Regards
  2. webizen

    webizen New Member

    Please provide your environment info:
    1. OS and version
    2. Hosting control panel if any
  3. jeckdenial

    jeckdenial New Member

    Hi

    I am running on CENTOS 5.5 x86_64 with WHM 11.26.20.

    If you need any more info please let me know.

    Thanx
  4. webizen

    webizen New Member

    Last edited: Jan 5, 2011
  5. jeckdenial

    jeckdenial New Member

    Hi there,

    I have made changes as you said.

    But the problem still there.

    I just got mail.

    At [08/Jan/2011:08:12:46 -0100], web server with pid=355 received unexpected signal=15, no core file is created. A new instance of web server will be started automatically!


    Any idea?
  6. mistwang

    mistwang LiteSpeed Staff

    Please check the PID in the error log file, see if it is a lshttpd process or a helper process.

    Some thing is killing that process with signal SIGTERM. It is not caused by litespeed bug.
    Does it happen regularly? or after a graceful restart? should tell from log file.
  7. jeckdenial

    jeckdenial New Member

    Hi Mistwang,

    I have found following in log

    2011-01-15 04:00:29.103 [NOTICE] SIGTERM received, shutdown disabled, turn off fake Apache httpd.
    2011-01-15 04:00:29.104 [NOTICE] [PID: 6699]: start cgid: 6771, /usr/local/lsws/bin/lscgid
    2011-01-15 04:00:29.104 [NOTICE] Server Restart Request via Signal...
    2011-01-15 04:00:29.104 [NOTICE] [6699] Graceful Restart...
    2011-01-15 04:00:29.104 [NOTICE] [Child: 6702] Start shutting down gracefully ...
    2011-01-15 04:00:29.104 [NOTICE] [Child: 6701] Start shutting down gracefully ...
    2011-01-15 04:00:29.104 [NOTICE] [PID: 6699]: start cgid: 6774, /usr/local/lsws/bin/lscgid

    yes it happens everyday at least 5 times.

    Please let me know if you need more info to help me out of this.
  8. mistwang

    mistwang LiteSpeed Staff

    That's normal graceful restart sequence. no crash.
    You should grep error_log with the PID received in the email.
  9. jeckdenial

    jeckdenial New Member

    Hi Mistwang,

    Thats fine as i have changed my version to 4.1RC3.

    So the problem looks like solved after changing version.

    Thanx n e way for help. you can close this.

    Regards
    Jeck

Share This Page