4.0b3 release

Discussion in 'LSWS 4.1 Release' started by mistwang, Nov 20, 2008.

  1. kc8yds

    kc8yds New Member


    downloaded and installed but am still getting the problem and had to go right back to 3.3.22

    got 46 copies of this in my email
    "At [05/Dec/2008:15:52:51 -0600], web server with pid=11873 received unexpected signal=11, no core file is created. A new instance of web server will be started automatically!"


    if you would like to take a look at it i'll send you the server login sometime between Friday night/Saturday to take a look
  2. mistwang

    mistwang LiteSpeed Staff

    Yes, I can take a look. Please PM me the login.
  3. kc8yds

    kc8yds New Member

    alright the info is sent
  4. mistwang

    mistwang LiteSpeed Staff

    bug fixed in the latest 4.0b3 release package, server is on 4.0b3 now.
  5. kc8yds

    kc8yds New Member

    are you still doing anything to the server? the panel is responding very slowly along with the websites on it -- this has only happened since you worked on the version 4

    also its showing up "Running short of concurrent connections." warnings
  6. mistwang

    mistwang LiteSpeed Staff

    Looks like still need to track down another problem. back to 3.3.22 now. Will look into it a little while later.
  7. mistwang

    mistwang LiteSpeed Staff

    Does it work better now? updated 4.0b3 package again.
  8. kc8yds

    kc8yds New Member

    pages are loading only partially on sites and in the panel (the ip i gave you)/config/confMgr.php?m=serv look at the bottom if you dont see what i am saying reload a few times --- i am getting the same results on the sites on that server as well

    specifically failing at 16,384 bytes into the transfer

    it is not loading slowly anymore though :)

    also a minor thing not a bug but improvement --- add php 5.2.7 to the /utility/buildPHP.php page
  9. mistwang

    mistwang LiteSpeed Staff

    Yeah, I noticed that as well. At least we made some progress. :)
    Back to 3.3.23 for now.
  10. d3vnul

    d3vnul New Member

    make that php 5.2.8 ;)
  11. quags

    quags New Member

    I've tried version, downloaded today.

    For me php suexec is not working. With it enabled I get:

    2008-12-12 13:37:36.062 [INFO] [72.30.79.111:58715-0#APVH_DOMAIN.com] connection to [uds://tmp/lshttpd/APVH_DOMAIN.com_Suphp.sock] on request #0, Connection timed out!

    and loading the url shows a time out error

    With it turned off everything works correctly
  12. Grzegorz Derebecki

    Grzegorz Derebecki New Member

    is there any chance to version for freebsd? 6.x or 7.x (standard version)
  13. d3vnul

    d3vnul New Member

    does beta packages require any license ? a trial or purchased license ?
  14. mistwang

    mistwang LiteSpeed Staff

    This problem has been fixed in the updated 4.0b3 package.

    It is available now.
  15. mistwang

    mistwang LiteSpeed Staff

    Yes, need a license for enterprise edition.
  16. Tony

    Tony Member

    For anyone out there who was brave enough to run it were you able to get SSI to work? I tried and I ended up with litespeed completly crashing out when someone visted a page with SSI. I ended up having to restart litespeed manually then switch the versions before there was another visitor on a page with ssi.

    Crash dump sent already but curious if anyone was able to get it to work.
  17. Tony

    Tony Member

    I found something odd with the mod_security support. I use the following ruleset to turn it off for a specific domain:

    Code:
    SecRule SERVER_NAME "domain.com" phase:1,nolog,allow,ctl:ruleEngine=off
    
    It does not seem to work with the LiteSpeed mod_security support.
  18. mistwang

    mistwang LiteSpeed Staff

    added support for this in the latest 4.0b3 update package.
  19. Tony

    Tony Member

    Does the SSI support something like this:

    <!--#exec cgi="/cgi-bin/counter.cgi" -->
  20. mistwang

    mistwang LiteSpeed Staff

    Yes, it should. However, it may be disabled by default due to "option IncludesNOEXEC", Apache's document is a bit vague on this. So, we may need to adjust the default behavior.

    You can try "#include virtual" see if it works.

Share This Page