4.1.2 file uploads give 503 error

Discussion in 'Install/Configuration' started by sip, Jul 16, 2011.

  1. sip

    sip New Member

    Upgraded to 4.1.2 and started getting 503 (oops! service not available in logs) and after downgrading to 4.1.1 everything works fine.

    The exact error message in log file is:
    oops! 503 Service Unavailable

    and obviously file uploads don't work. 4.1.1 it works all fine.

    Regards
  2. Thoran

    Thoran New Member

    I have the same issue.
  3. webizen

    webizen New Member

    stay with 4.1.1 for now. will address the issue shortly.
  4. bradjordan111

    bradjordan111 New Member

    Hi, I am using this code to upload my images.

    Code:
    <?php 
    $file_realname = trim($_fileS['userfile']['name']); 
    $uploaddir = "images/";
    if (move_uploaded_file($_fileS['userfile']['tmp_name'], $uploaddir . $file_realname)) 
    { 
    echo $file_realname." has been uploaded"; 
    } 
    else 
    { 
    echo "<strong>$file_realname</strong> did not upload!"; 
    } 
    ?> 
    And I get this kind of error when I tries to upload a big file.

    Notice: Undefined index: userfile in C:\Program files\Apache Group\Apache2\htdocs\FYP\upload\upload.php on line 2

    Notice: Undefined index: userfile in C:\Program files\Apache Group\Apache2\htdocs\FYP\upload\upload.php on line 5
    did not upload!

    Is there a way to expend the limit of the file size? And restrict user to upload all know pictures type only.
  5. NiteWave

    NiteWave Administrator

    are you using lsws 4.1.2 ? the issue was resolved in later 4.1.2 build.

    please upgrade to latest 4.1.4, see if still problem.
  6. webizen

    webizen New Member

    Are you running PHP on a windows server? The path to upload.php is Windows style. LSWS does not run on Windows server.


Share This Page