4.2 - 503 Errors

Discussion in 'Bug Reports' started by JulesR, Sep 23, 2012.

  1. NiteWave

    NiteWave Administrator

    I think daemon mode should apply for server level ext app lsphp only.

    in daemon mode, root lsphp process is running as root, it can fork child php process with userid:group id.

    demon mode lsphp should serve for all users, not for a single user.

    for a single user, non-daemon mode is enough.
  2. bzerangue

    bzerangue New Member

    I had it set to suEXEC in the server level (for all users) not the app level, so that's why I don't understand the original response to why it's causing a 503 error and to get rid of the 503 you have to turn off suEXEC mode altogether for no 503 to occur.
  3. NiteWave

    NiteWave Administrator

    should change to
    lsadmin console->Server->External App->lsphp5
    to be more clear

    to summary, external app lsphp defined at virtual host level can't set "Run On Start Up" to "suEXEC Daemon", otherwise 503 error. other values are ok.

    Virtual Host Template >> PHP_SuEXEC
    implement php suEXEC by:
    External App:$VH_NAME_lsphp ->
    suEXEC User:Not Set
    suEXEC Group:Not Set

    and

    Security->ExtApp Set UID Mode: DocRoot UID
  4. bzerangue

    bzerangue New Member

    @mistwang and @Nitewave -

    OK, now things are making sense. Forgive me for my frustration above. Thanks for being patient with me.

    The issue was that I needed to have my Virtual Host Template > PHP_SuEXEC > External App > Run On Start Up set to "Not Set" and my Server Level set to suEXEC daemon mode.

    The problem is that I had it set to suEXEC daemon mode on both the Virtual Host Level and the Server Level. To fix it was so I could use suEXEC daemon mode was not to set Run On Start Up to "No" at the Virtual Host Level, BUT to set it to "Not Set" at the Virtual Host Level.

    So now everything works correctly. Sorry for the confusion that I caused. Thank you both for your gracious and patient help.
  5. NiteWave

    NiteWave Administrator

    Hi,

    since I've not tested this special setting, so need discuss with you more and make it clear.

    to ensure a specific site is served by daemon mode lsphp, need check the process's parent process, if it's litespeed process, then not daemon mode lsphp; if parent process is lsphp running at root, then it's daemon mode lsphp. can check it by "pstree -p" as well.

Share This Page