408.shtml error and then litespeed stalls

Discussion in 'General' started by pguy, Apr 5, 2009.

  1. pguy

    pguy New Member

    Hello,

    We are seeing the following error repeatedly.

    2009-04-05 06:17:55.950 [INFO] [203.212.239.28:53692-0#APVH_xxx.com] File not found [/home/xxx/public_html/408.shtml]
    2009-04-05 06:23:35.266 [INFO] [203.212.239.28:42786-0#APVH_xxx.com] File not found [/home/xxx/public_html/408.shtml]
    2009-04-05 06:23:50.171 [INFO] [203.212.239.28:43458-0#APVH_xxx.com] File not found [/home/xxx/public_html/408.shtml]
    2009-04-05 06:25:08.028 [INFO] [203.212.239.28:52639-0#APVH_xxx.com] File not found [/home/xxx/public_html/408.shtml]
    2009-04-05 06:26:52.944 [INFO] [203.212.239.28:58027-0#APVH_xxx.com] File not found [/home/xxx/public_html/408.shtm

    Can't seem to figure out why - the error shows up, then LS spirals out by running too many processes and the only way then is to kill lsphp & then restart litespeed.

    any leads?
  2. mistwang

    mistwang LiteSpeed Staff

    You need to check why the request takes so long, usually, it is a PHP/MySQL issue.
    Also, try our 4.0.1 release package see if it helps or not. Just change the version number in the download link to get it.
  3. pguy

    pguy New Member

    Hi, I tried. It helped for a bit and then again the server spiralled out. This time though it was able to cut on the processes much faster than prev times. But the problem still exists ..
  4. anewday

    anewday Moderator

    I still see many 404.shtml errors in the log with 4.01.
  5. pguy

    pguy New Member

    On the stats page, when the server went out of control I saw the following statistic

    EAProc Idle - 170
  6. mistwang

    mistwang LiteSpeed Staff

    You probably configured the number of process of that external application too high?
    Show me the configuration.
  7. pguy

    pguy New Member

    PHP_LSAPI_MAX_REQUESTS=200
    PHP_LSAPI_CHILDREN=200
    LSAPI_MAX_IDLE_CHILDREN=60
    LSAPI_AVOID_FORK=1

    Process Soft limit 500
    Hard Limit 750
  8. anewday

    anewday Moderator

    PHP_LSAPI_CHILDREN is way too high. Start with 20. You should increase PHP_LSAPI_MAX_REQUESTS and lower LSAPI_MAX_IDLE_CHILDREN a lot more. What value did you set for Instances?
  9. pguy

    pguy New Member

    Modified settings to

    PHP_LSAPI_MAX_REQUESTS=300
    PHP_LSAPI_CHILDREN=30
    LSAPI_MAX_IDLE_CHILDREN=20
    LSAPI_AVOID_FORK=1

    Instances, set to 1

    Lets see how this goes. Anything else I need to check?

  10. anewday

    anewday Moderator

    I think you should increase PHP_LSAPI_MAX_REQUESTS a lot more and lower LSAPI_MAX_IDLE_CHILDREN What's the value for Max Connections? I set mine to match PHP_LSAPI_CHILDREN
  11. pguy

    pguy New Member

    Done, I've set PHP_LSAPI_CHILDREN to the same no as Max Connections = 30

Share This Page