500 error using htaccess mod rewrite

Discussion in 'Install/Configuration' started by TRANSFORM, Aug 29, 2011.

  1. TRANSFORM

    TRANSFORM New Member

    Hello. Moving an apache site over to litespeed. The apache site used modwrite to take the index.php out of the url.

    I have enabled .htaccess in Litespeed
    I have allowed effectively 'AllowOverride All'
    I have put the .htaccess file in the root of the site

    As soon as I turn on the redirect rule website starts providing a SERVER 500 – Internal Server Error page.

    The Litespeed Admin console reports –

    2011-08-29 06:21:01.618
    ERROR [192.168.42.30:36636-0#scas] Maximum number of redirect reached.

    Here are the contents of the htaccess file:

    php_value memory_limit 128M
    php_value upload_max_filesize 100M
    php_value post_max_size 110M
    RewriteEngine On

    RewriteCond $1 !^(admin\.php|download\.php|apple-touch-icon\.png|downloads|export|favicon\.ico|images|images-css|index\.php|js|system|template|themes) [NC]
    RewriteRule ^(.*)$ /sacramento.aero/index.php/$1 [L]
    Last edited: Aug 29, 2011
  2. webizen

    webizen New Member

    please enable rewrite logging to see if anything wrong with your rewrite.

Share This Page