503 Error: Litespeed Web Server Enterprise v4.2.4

Discussion in 'Install/Configuration' started by Legba, Nov 3, 2013.

  1. Legba

    Legba New Member

    I have tried for days trying to overcome an issue with Litespeed. I have read every post I could find and have done everything they all said to no avail. I have a PHP script that needs to run for at least 20 minutes. I initially set the max executuion time to 3600 thinking that would do it. However, no matter what I do after about 300 seconds I get the following in the error log:

    2013-11-03 09:05:01.085 [STDERR] Killing runaway process PID: 27214 with SIGTERM

    and the web page displayed is:

    503 Service Unavailable
    The server is temporarily busy, try again later!

    I have set every remotely relevant timeout I could find in the Litespeed config to 100 times its initial value and still I get the same issue after about 300 seconds.

    Please could someone help?

    Below are my settings, and they are confirmed using phpinfo.php

    Tuning:
    Max Connections 2000
    Max SSL Connections 500
    Connection Timeout (secs) 36000
    Max Keep-Alive Requests 32000
    Smart Keep-Alive (I have tried with this value set to No and Yes)
    Keep-Alive Timeout (secs) 60
    PHP5:
    Initial Request Timeout (secs) 36000
    Max Idle Time 1000
  2. NiteWave

    NiteWave Administrator

  3. bobykus

    bobykus Member

    Mine is dying too on

    Killing runaway process PID: 463 with SIGTERM
    2014-03-04 09:27:07.874 [STDERR] Child process with pid: 463 was killed by signal: 15, core dump: 0

    which is super suxxx. It happens 2-3 times a day on servers with high i/o.
    And it is not just php dying, whole web server stop respongind.
    Why? Any way to avoid it?
  4. NiteWave

    NiteWave Administrator

    WHM/cPanel installed ?
    check the setting of log rotate in WHM, it may cause restart
  5. bobykus

    bobykus Member

    No, not WHM/cPanel. What it have todo with log rotate?

Share This Page