503 Errors in Wordpress

Discussion in 'General' started by jayjaybaby, Aug 20, 2009.

  1. jayjaybaby

    jayjaybaby New Member

    I recently have been getting 503 errors on a wordpress site - it only
    happens on this certain site running wordpress (all other PHP, non
    wordpress sites work). I even uploaded a phpinfo file to the wordpress site and that displays fine. As for the 503 errors, error log shows entries like so:

    Code:
    2009-08-20 12:35:45.247 [INFO] [67.70.93.222:1307-0#APVH_www.xxxxxx.com]
    HttpExtConnector state: 8, request body sent: 0, response body size:
    0, response body sent:0, left in buffer: 8, attempts: 0.
    2009-08-20 12:35:45.247 [INFO] [67.70.93.222:1307-0#APVH_www.xxxxxx.com]
    File not found [/home/rfvncom/domains/xxxxxx.com/public_html/408.shtml]
    2009-08-20 12:35:50.015 [NOTICE]
    [67.70.93.222:1313-0#APVH_www.xxxxxx.com] No request delivery
    notification has been received from LSAPI process:19455, possible run
    away process.
    2009-08-20 12:35:50.015 [NOTICE]
    [67.70.93.222:1313-0#APVH_www.xxxxxx.com] Retry with new instance.
    2009-08-20 12:36:04.006 [INFO]
    [65.55.106.114:43074-0#APVH_www.xxxxxx.com] ExtConn timed out while
    processing.
    2009-08-20 12:36:04.006 [INFO]
    [65.55.106.114:43074-0#APVH_www.xxxxxx.com] connection to
    [uds://tmp/lshttpd/APVH_www.xxxxxx.com_Suphp.sock] on request #0,
    confirmed: 1, Connection timed out!
    2009-08-20 12:36:04.006 [NOTICE]
    [65.55.106.114:43074-0#APVH_www.xxxxxx.com] Suspious request timeout,
    associtated process: 19465, running: 1.
    2009-08-20 12:36:16.451 [INFO] [67.70.93.222:1313-0#APVH_www.xxxxxx.com]
    Connection idle time: 31 while in state: 5 watching for event: 25,close!
    2009-08-20 12:36:16.451 [NOTICE]
    [67.70.93.222:1313-0#APVH_www.xxxxxx.com] Content len: 0, Request line:
    (null)
    2009-08-20 12:36:16.451 [INFO] [67.70.93.222:1313-0#APVH_www.xxxxxx.com]
    HttpExtConnector state: 8, request body sent: 0, response body size:
    0, response body sent:0, left in buffer: 10982, attempts: 0.
    2009-08-20 12:36:16.451 [INFO] [67.70.93.222:1313-0#APVH_www.xxxxxx.com]
    File not found [/home/rfvncom/domains/xxxxxx.com/public_html/408.shtml]
    2009-08-20 12:36:24.039 [INFO]
    [66.249.68.200:58165-0#APVH_www.xxxxxx.com] ExtConn timed out while
    processing.
    2009-08-20 12:36:24.039 [INFO]
    [66.249.68.200:58165-0#APVH_www.xxxxxx.com] connection to
    [uds://tmp/lshttpd/APVH_www.xxxxxx.com_Suphp.sock] on request #0,
    confirmed: 1, Connection timed out!
    2009-08-20 12:36:24.040 [NOTICE]
    [66.249.68.200:58165-0#APVH_www.xxxxxx.com] Suspious request timeout,
    associtated process: 19485, running: 1.
    2009-08-20 12:36:25.003 [INFO]
    [66.249.68.200:58165-0#APVH_www.xxxxxx.com] Connection idle time: 31
    while in state: 5 watching for event: 25,close!
    2009-08-20 12:36:25.003 [NOTICE]
    [66.249.68.200:58165-0#APVH_www.xxxxxx.com] Content len: 0, Request line:
    
    It only started recently, but it sounds like something in lsws is
    conflicting with wordpress? Any ideas?
  2. mistwang

    mistwang LiteSpeed Staff

    It is a problem with your PHP, maybe you upgrade php recently.
    you can try strace the PHP process for that user account.
  3. jayjaybaby

    jayjaybaby New Member

    Nothing has been changed recently PHP configuration + LSWS configuration wise. We are using PHP 5.2.9 + LSWS 4.0.3. Are you saying it is a PHP config issue or rather something wrong with the actual script?
  4. jayjaybaby

    jayjaybaby New Member

    Yep, it is an actual script issue. Removing all wordpress plugins allows the site to load without error. Time to find out which plugin exactly is causing the issue, then troubleshoot further from there.
  5. mistwang

    mistwang LiteSpeed Staff

    That's the right approach. :)

Share This Page