admin password

Discussion in 'Bug Reports' started by shdwkat, Aug 1, 2003.

  1. shdwkat

    shdwkat New Member

    I setup the server as per the installation instructions.
    I really like it however I have encountered a small problem.

    It will not acccept any password I try to set up with 'admpass.sh'

    when I examine the htpasswd file I see this appeneded to it
    'incorrectly built binary which accesses errno, h_errno or
    _res directly. Needs to be fixed'

    any suggestions

    shdwkat
  2. mistwang

    mistwang LiteSpeed Staff

    rebuild php binary

    Thank you for trying our server.

    Can you tell me more information about your system?
    Linux or other OS, version of (g)libc?
    It is likely because that you use newer version of (g)libc.

    The prebuilt php binary is not good.
    You can built php binary yourself if you have the environment.
    use following commands.

    cd php-4.3.1
    ./configure --enable-fastcgi --with-config-file-path=../conf
    make
    cp -f sapi/cgi/php [lsws_home]/admin/fcgi-bin/admin_php
    cp -f sapi/cgi/php [lsws_home]/fcgi-bin/php

    and run admpass.sh again.

    If you can not compile php yourself, we can build it for you after we get detail information about your system (if we can setup the same environment).

    Best,
    mistwang
  3. shdwkat

    shdwkat New Member

    I am using Red Hat version 9.
    I downlaoded the PHP4.3.2 and compiled as per your instructions.

    Now I get serice not available.

    any new ideas ?

    thanks

    scott
  4. mistwang

    mistwang LiteSpeed Staff

    compile php 4.3.2

    It is documented already :)

    Due to bugs in Fast CGI interface of PHP 4.3.2, it has to be configured with additional option --enable-discard-path, please disregard what is said about this option in its README.FastCGI.

    And 4.3.2 does not populate path info correctly, so we still recommend 4.3.1.

    We already submit bug reports to php.org.

    Best regards,
    Mistwang
  5. mistwang

    mistwang LiteSpeed Staff

    try again

    We find a way to fix the "errno" error message in PHP binary, please download our repackaged binary package and try again.

    Best Regards,
    Mistwang
  6. shdwkat

    shdwkat New Member

    Thanks for your help !! :D

    everything works great now. A very fast web server.

    scott[/b]

Share This Page