allow_url_fopen and tmp problem

Discussion in 'Install/Configuration' started by BND, Mar 1, 2010.

  1. BND

    BND New Member

    Hello,
    i'm LiteSpeed 2cpu ent. licensed user. I'm using Centos 5.3 with cpanel latest.

    i have 2 problems.

    * allow_url_fopen is ON in /usr/local/lsws/admin/conf/php.ini but file_get_contents and some curl functions not running. I used php.ini (allow_url_fopen = On) but not runned.

    * My tmp size is 2 gb. The folder size fill up within 12-15 hours. I'm using a corntab script rm -rf /tmp/* . But i don't like this. What else can I do?

    Thank you for your valuable assistance.
    Regards.
    BND Corp
  2. mistwang

    mistwang LiteSpeed Staff

  3. BND

    BND New Member

    The php files not running now.

    <?php
    phpinfo();
    ?>

    returning emtpy page. What is this?
  4. mistwang

    mistwang LiteSpeed Staff

    It means PHP has not been configured properly. Are you using any control panel?
  5. BND

    BND New Member

    i'm using centos 5.3 (64 bit) with cpanel 11.25. Some php files not runing. But blogs, forums running. I did not understand it. this crazy problem.

    Example: serverproxies.com blog is running but serverproxies.com/phpinfo.php not running.

    serverproxies.com/phpinfo.php codes:

    <?php
    echo phpinfo();
    ?>

    Thank you for your support.
  6. mistwang

    mistwang LiteSpeed Staff

    You should remove "echo".
  7. BND

    BND New Member

    removed echo. but returned same empty page.
    <?php
    phpinfo();
    ?>
  8. mistwang

    mistwang LiteSpeed Staff

    looks like that file has been served as static html file.
    Please check the .htaccess see if something override the MIME type for ".php" to "text/html".
  9. BND

    BND New Member

    htaccess:


    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress


    I changed directory for this page. But i see same empty page.

    serverproxies.com/deneme/test.php
  10. BND

    BND New Member

    and error_lod said:
    [01-Mar-2010 22:02:56] PHP Warning: phpinfo() has been disabled for security reasons in /home/serverpr/public_html/deneme/test.php on line 2
  11. mistwang

    mistwang LiteSpeed Staff

    That's the reason, please check /usr/local/lib/php.ini, that's the php.ini used in cPanel environment.
  12. BND

    BND New Member

    i resolved this problem thanks. But now, litespeed Admin Web Consol is returning empty page in whm.
  13. mistwang

    mistwang LiteSpeed Staff

    Maybe you should restore the php.ini under admin/conf/ directory.
  14. BND

    BND New Member

    My php.ini file is broken. How can I restore? Or, how do I re-install? I did uninstall and re-installed. But not.
  15. BND

    BND New Member

    i removed the php.ini file and admin console is running now.
  16. mistwang

    mistwang LiteSpeed Staff

    You can copy admin/conf/php.ini from a expanded installation package.
  17. BND

    BND New Member

    Thank you. Does Litespeed support xmlrpc? i can not using xmlrpc (in wp).
  18. mistwang

    mistwang LiteSpeed Staff

    It is a PHP feature, not directly related to LiteSpeed. should work fine if corresponding PHP module is available.
  19. soyturk

    soyturk New Member

    build php to your apache php configuration

Share This Page