APC Not enabled?

Discussion in 'Install/Configuration' started by awood969, Jan 23, 2012.

  1. awood969

    awood969 New Member

    Hi guys/gals,

    Just need some help with regards to APC.

    I have just recompiled PHP using the Litespeed web panel selecting the APC add-on. This is for PHP version 5.3.8.

    After the process completing without error i then adjusted my php.ini file to include extension=apc.so next to the other extensions i run (nothing conflicting).

    I restarted the server and loaded up a phpinfo() page, only to discover that apc isn't enabled, and not even shown on the phpinfo() page.

    Could anybody shine some light on this for me?

    Thanks
    Andrew
  2. webizen

    webizen New Member

    make sure the php.ini you enabled apc.so in is the one used by lsphp5.

  3. awood969

    awood969 New Member

    Yes its the been added to the correct php.ini. Any other ideas? I still haven't fixed it :-(
  4. webizen

    webizen New Member

    paste here the output of

  5. awood969

    awood969 New Member

    Code:
    PHP Warning:  PHP Startup: Unable to load dynamic library './geoip.so' - ./geoip.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning:  PHP Startup: Unable to load dynamic library './http.so' - ./http.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning:  PHP Startup: Unable to load dynamic library './apc.so' - ./apc.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP Warning:  Unknown: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'UTC' for 'UTC/0.0/no DST' instead in Unknown on line 0
    The laugh is geoip is fine, we have it working in scripts
  6. webizen

    webizen New Member

    maybe your lsws does not use default lsphp (/usr/local/lsws/fcgi-bin/lsphp5). check binary path (Admin CP => Configuration => Server => External App => lsphp5 => command).

Share This Page