AuthType does not work for subdirs

Discussion in 'Bug Reports' started by bobykus, Dec 10, 2012.

  1. bobykus

    bobykus Member

  2. bobykus

    bobykus Member

    Any body here?
  3. PSS

    PSS Member

    Just a guess:

    Make sure have / in the end of both URI and Location.

    Static Context Definition
    URI /private/
    Location private/
  4. bobykus

    bobykus Member

    Location? is it required? .htaccess is in folder I want to protect, why
    I have to put location tag there?
  5. mistwang

    mistwang LiteSpeed Staff

    It should work.
    When you test the second URL, you should close all your browser window first, browser will remember the authentication when you test the first URL.
    Is there a .htacess under /subdir/cgi/ folder? what is the content?
    Also, you can switch back to Apache temporarily to verify your configuration see if it is working as you expected or not.
  6. bobykus

    bobykus Member

    Switch back is not an option. No .htaccess in subfolders.
  7. mistwang

    mistwang LiteSpeed Staff

    Please try 4.2.2 release, it should work now.

    /usr/local/lsws/admin/misc/lsup.sh -f -v 4.2.2
  8. bobykus

    bobykus Member

    Oh! You have new version released! Can I see change log or release notes?
  9. mistwang

    mistwang LiteSpeed Staff

Share This Page