[AutoUpdate] Failed, updateagent exit code: 3

Discussion in 'Install/Configuration' started by TomBG, Mar 18, 2009.

  1. TomBG

    TomBG New Member

    Any ideas?

    root:/home/lsws# cat autoupdate/update.log
    [2009-02-22 19:51:40] Checking for new release...
    [2009-02-22 19:51:41] [ERROR] Unknown response from server.
    [2009-02-22 22:43:12] Checking for new release...
    [2009-02-22 22:43:12] [ERROR] Unknown response from server.
    [2009-02-23 22:43:13] Checking for new release...
    [2009-02-23 22:43:14] [ERROR] Unknown response from server.
    .
    .
    .

    [2009-03-16 18:20:37] Checking for new release...
    [2009-03-16 18:20:38] [ERROR] Unknown response from server.
    [2009-03-18 18:14:39] Checking for new release...
    [2009-03-18 18:14:40] [ERROR] Unknown response from server.
    [2009-03-18 18:19:27] Checking for new release...
    [2009-03-18 18:19:27] [ERROR] Unknown response from server.
  2. mistwang

    mistwang LiteSpeed Staff

    Maybe your server has difficulties to reach update.litesspeedtech.com port 80.
  3. TomBG

    TomBG New Member

    Server can connect to that URL without problems.
  4. TomBG

    TomBG New Member

    Any ideas? I'd really like to be able to upgrade easily over the web.
  5. TomBG

    TomBG New Member

    Server can connect, but auto update still isn't working. Any ideas/suggestions?
  6. mistwang

    mistwang LiteSpeed Staff

    Are you using 32bit binary for a 64 bit linux server?
  7. TomBG

    TomBG New Member


    I'm running a 32-bit FreeBSD binary. Here's the most recent output from autoupdate/update.log:


    [2009-04-20 06:35:09] Checking for new release...
    [2009-04-20 06:35:10] [ERROR] Unknown response from server.
    [2009-04-20 23:49:27] Checking for new release...
    [2009-04-20 23:49:28] [ERROR] Unknown response from server.
    [2009-04-21 00:10:15] Checking for new release...
    [2009-04-21 00:10:15] [ERROR] Unknown response from server.
    [2009-04-21 00:11:15] Checking for new release...
    [2009-04-21 00:11:15] [ERROR] Unknown response from server.


    I am able to lynx to that URL (without the extra "s" which I'm assuming was a typo) and get a File Not Found error.
    Last edited: Apr 21, 2009
  8. mistwang

    mistwang LiteSpeed Staff

    Which package exactly? for freebsd6 or freebsd (for 4 and 5)?
  9. TomBG

    TomBG New Member

    freebsd6 -- running on FreeBSD 7.1.
  10. mistwang

    mistwang LiteSpeed Staff

    I have installed a fresh freebsd 7.1 in our lab. installed /usr/ports/misc/compat6x/
    installed 4.0.1, it detects the new release and downloaded 4.0.2 automatically.
  11. anewday

    anewday Moderator

    I've been getting this for the past few days with 4.0.11

    2009-10-16 17:55:06.616 NOTICE [AutoUpdate] Checking for new releases...
    2009-10-16 17:55:06.714 NOTICE [AutoUpdate] Failed, updateagent exit code: 3
  12. mistwang

    mistwang LiteSpeed Staff

    should be fixed by now. a glitch when we migrate to a new server.

Share This Page