Build Matching PHP Binary **ERROR** Could not get into php/sapi directory

Discussion in 'Install/Configuration' started by Prime Media, Jul 13, 2013.

  1. Prime Media

    Prime Media New Member

    Hello,

    I was trying to Build Matching PHP Binary on my DirectAdmin server as I updated to PHP 5.4.17.

    This is the command I'm using:
    Code:
    /usr/local/directadmin/plugins/litespeed/admin/build_lsphp
    But I keep on getting this error message:

    Code:
    Query lastest LSAPI version: 6.2
    Retrieving LSAPI archive
    2013-07-13 02:00:21 URL:http://www.litespeedtech.com/packages/lsapi/php-litespeed-6.2.tgz [34986/34986] -> "php-litespeed-6.2.tgz" [1]
    /usr/local/directadmin/plugins/litespeed/admin/build_lsphp: line 55: cd: php-/sapi: No such file or directory
    **ERROR** Could not get into php/sapi directory
    This is what's on line 55:

    Code:
    cd php-${PHP_VERSION}/sapi
    So my question is, what's the best way to fix this? Can you kindly share the shell command with me?

    Thank you for your help!
  2. webizen

    webizen New Member

    the latest DA CustomBuild 2.0 breaks the script. will let you know when a fix is available.
  3. Lauren

    Lauren LiteSpeed Staff Staff Member

    when you build matching php, you need to first build php 5.4.17 from DA for apache, then run build matching php from litespeed plugin.

    Code:
    cd /usr/local/directadmin/custombuild
    ./build set php5_ver 5.4
    ./build update
    ./build php n
    
    when this finish, go to litespeed plugin to build matching php.

    The current plugin package has mismatched version number, you can download v 1.0.3. no real changes, just fixed the version.
  4. Lauren

    Lauren LiteSpeed Staff Staff Member

    please upgrade to da_plugin v1.0.4
    Addressed the compatibility issue with custom build 2.0.

Share This Page