Cannot load mysql extension. Please check your PHP configuration.

Discussion in 'Install/Configuration' started by .Bob, Aug 1, 2008.

  1. .Bob

    .Bob New Member

    Sorry for bombarding you with all these questions :p.


    This might be a little off topic as to LiteSpeed problems, but I would appreciate it if you can help me out on this one, as you can tell I'm a newbie.


    So basically, whenever I enter phpmyadmin it warns me of the following error:
    Cannot load mysql extension. Please check your PHP configuration.


    Also when trying to install scripts, they cant seem to detect that mysql is installed on the server.



    I' guessing those two problems are connected. How would I go about fixing this?


    Additional info:
    Running CentOS 5 with php 5, curl, zend optimizer, ioncube
    PHPInfo file shows mysql as configured


    Thanks again,
    Bob
    Last edited: Aug 1, 2008
  2. mistwang

    mistwang LiteSpeed Staff

    check the mysql socket configuration, you may need to change it in php.ini to match your mysql installation.
  3. .Bob

    .Bob New Member




    MySQL works, because I restored a backup of the forum and now the forum is wokring fine.
    It's just that when it trys to detect mysql it isnt detected




    So how do I find out what the settings are for my mysql installation so I know what to put in php.ini?
    Last edited: Aug 1, 2008
  4. mistwang

    mistwang LiteSpeed Staff

    PHP 5 has two mysql modules, one is "mysql", another one is "mysqli", make sure the module that the app wanted shows in phpinfo() page.
  5. .Bob

    .Bob New Member

    Ah, had to compile with the --with-mysql. Thanks for your help.

Share This Page