Can't change PHP suEXEC Max Conn after update to 4.2.14

Discussion in 'Install/Configuration' started by Home Alone, Aug 14, 2014.

  1. Home Alone

    Home Alone New Member

    After updating to 4.2.14 the PHP suEXEC Max Conn value reverted to the default of 25. When I tried to increase it the following error message appears:

    Please fix the error(s) first: No field has been changed, no need to update.

    I can't find the error this message references. I checked all the server logs. When I downgrade to 4.2.12 the message goes away and I am able to change the PHP suEXEC Max Conn value.
  2. NiteWave

    NiteWave Administrator

    Home Alone likes this.
  3. Home Alone

    Home Alone New Member

    That thread didn't address the issue. It's not a problem with gzip. I can't adjust the PHP suEXEC Max Conn. I have it set to 150 in the General configuration but it only allocates 25, the default value.

    This is on a server that has CloudLinux and cPanel.
  4. Michael

    Michael Administrator Staff Member

    Howdy,

    We're a little unclear as to the exact problem you're facing. In your first post it seems like you are unable to save the change in the WebAdmin GUI (you get an error). But in your new post it sounds like you are able to save the setting, but it is not being used. Which of these is correct?

    Cheers,

    Michael
  5. Home Alone

    Home Alone New Member

    Both problems I listed were correct. I figured it out. I had to manually update the Apache include file:

    <IfModule LiteSpeed>
    LSPHP_ProcessGroup on
    LSPHP_Workers 150
    </IfModule>

    This seems to be the only way to change the PHP suEXEC Max Conn value.
  6. Michael

    Michael Administrator Staff Member

    Ah. Sorry. My next question would have been whether you were using ProcessGroup. That is the way to change the max connections setting for ProcessGroup. Here's the wiki for controlling the number of connections: http://www.litespeedtech.com/support/wiki/doku.php?id=litespeed_wiki:php:concurrency

    Still, I'm surprised you got that error. And that shouldn't have changed between 4.2.12 and 4.2.14. Were you using ProcessGroup when you got this problem?

    Michael
  7. Home Alone

    Home Alone New Member

    Yes, I was using ProcessGroup when I got that error.
  8. Michael

    Michael Administrator Staff Member

    Duly noted. Thanks for reporting this!

    Michael

Share This Page