Can't connect to local MySQL server through socket '/tmp/mysql.sock' (111) site:http:

Discussion in 'Install/Configuration' started by pooyan, Oct 17, 2012.

  1. pooyan

    pooyan New Member

    I installed lsws on DA
    when i run
    service httpd stop
    service lsws start
    Also i compiled PHP via console

    and test a website display this error:
    Can't connect to local MySQL server through socket '/tmp/mysql.sock' (111)


    I searched on this forum and find related post and run this command but problem not fixed,

    # ln /var/lib/mysql/mysql.sock /tmp
    ln: creating hard link `/tmp/mysql.sock' to `/var/lib/mysql/mysql.sock': File exists



    Please help me
    regards
  2. webizen

    webizen New Member

    looks like /tmp/mysql.sock was already there. double check /tmp/mysql.sock make sure it is socket type file. if not, remove it and run ln command again.

  3. cmanns

    cmanns New Member

    Just use 127.0.0.1 for now

    One thing if you don't have all dev packages for MySQL/MariaDB/PerconaDB the LiteSpeed compile will give MySQL errors. Make sure 127.0.0.1 works first (ensure your user allows connections from localhost first, it should)

    You should be all set then. Also next time compile the mysql socket to the proper directory mysql creates it in...
  4. pooyan

    pooyan New Member

    But it did not solve my problem.
  5. pooyan

    pooyan New Member

    Yes, 127.0.0.1 allowd
  6. webizen

    webizen New Member

    you can modify mysql.default_socket in php.ini (use phpinfo page to show which php.ini in use) to point to /var/lib/mysql/mysql.sock
  7. pooyan

    pooyan New Member

    I changed all php.ini value to mysql.default_socket = /var/lib/mysql/mysql.sock

    But now after start lsws and test a website display this error:
    Client does not support authentication protocol requested by server; consider upgrading MySQL client
  8. cmanns

    cmanns New Member

    test first with 127.0.0.1

    MySQL sockets work fine with LSPHP 5.3.x and up. I've used LSWS for years and support 3rd party client whom run it and it's 2 cpu versions and such.

    Read error logs.

    Also if it said upgrade, make sure you have ALL MySQL packages installed

    yum search all MySQL

    install the dev packages the client the libraries whatever there is make sure you have it all. Then re-compile php with mysql, mysqli, socket option too. The php.ini one can be wonky webzian guy, as a web host since 15 years whom is developing an OS and Web Hosting panel in my spare time I think I know best. I get paid thousands by people for a few hours of my tuning/cluster setups. This is the end of my free help sadly the OP doesn't seem to know what doing.

    Good luck soliving your issue, if 127.0.0.1 works then whats the issue, ditch the socket not every php application works good with mysql socket.
  9. webizen

    webizen New Member

    this is not lsws issue but mysql client is old. to work around this, add a line to your my.cnf (usually /etc/my.cnf)

Share This Page