CGI does not work in LSWS 1.3.1

Discussion in 'Bug Reports' started by bogus, Mar 20, 2004.

  1. bogus

    bogus New Member

    And the logs/stderr.log says :
    lsws/DEFAULT/cgi-bin/helloworld: fork: Resource temporarily unavailable


    Whereas I'm still able to launch programs from the shell, menus, ... so it is not a system wide resource exhaustion (I've have plenty of free swap & ram).

    Any hint?

    Thanks.
  2. mistwang

    mistwang LiteSpeed Staff

    You probably run a lot of other processes with user that lsws is running as, you need to go to server "security" tab, change the process limit in "CGI Resource Limits" table, either increase the limit or set it to "0" to disable it.

    Let me know whether it works.
  3. bogus

    bogus New Member

    You are right, it works. When testing as normal user, the default limit may seem low, especially if the user runs Gnome or KDE desktops (many background processes).

    Thank you !
  4. bogus

    bogus New Member

    Limit too low on LInux

    Hello,

    PLease note that linux does not make a difference betweeb threads and processes. So your CGI process limit is too low, because PHP FastCGI threads are already many more (you launch more than 25 of them by default, and set the limit as low as 25...)

    Sincerely,
  5. mistwang

    mistwang LiteSpeed Staff

    Thanks, we will increase the default limit.

Share This Page