Change workers

Discussion in 'General' started by nikoc1337, Feb 24, 2013.

  1. nikoc1337

    nikoc1337 New Member

    Hi. IM running free litespeed on a dedicated server with 8GB ram. I want to know how can i change how many workers i want to be used and such configurations.

    Im running a small wordpress site and with 30-40 users online it is lagging.
  2. webizen

    webizen New Member

    run 'top -c' from command line and see how much system load and which process consume most cpu cycles.
  3. nikoc1337

    nikoc1337 New Member


    Code:
    top - 06:38:15 up 23:07,  1 user,  load average: 0.53, 0.48, 0.40
    Tasks: 204 total,   2 running, 202 sleeping,   0 stopped,   0 zombie
    Cpu(s):  8.6%us,  0.5%sy,  0.0%ni, 90.9%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
    Mem:   8151976k total,  2661480k used,  5490496k free,   251572k buffers
    Swap: 10190840k total,        0k used, 10190840k free,  1602312k cached
    
      PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
     1085 nobody    16   0  164m  37m 8336 S 11.0  0.5   0:31.80 lsphp5:/home/igtrai
      589 nobody    16   0  170m  43m 8308 S 10.6  0.5   0:33.23 lsphp5             
     1062 nobody    16   0  164m  37m 8272 S 10.3  0.5   0:15.52 lsphp5:/home/igtrai
     3970 mysql     15   0 1186m 239m 5644 S  8.6  3.0  53:54.18 /usr/sbin/mysqld --
    31509 nobody    16   0  171m  44m 8356 S  8.0  0.6   2:38.78 lsphp5             
    29789 nobody    16   0  165m  38m 8316 S  7.3  0.5   2:29.64 lsphp5             
     1495 nobody    16   0  154m  27m 7696 S  4.7  0.3   0:00.14 lsphp5             
    31797 nobody    16   0  165m  38m 8324 R  4.3  0.5   2:39.47 lsphp5:/home/igtrai
    32729 nobody    16   0  164m  38m 8316 S  3.7  0.5   0:53.18 lsphp5             
      676 nobody    16   0  170m  43m 8320 S  3.0  0.6   0:45.86 lsphp5:/home/igtrai
     1494 root      15   0 12764 1184  832 R  0.3  0.0   0:00.02 top -c             
    20105 nobody     0 -19 38404  17m 1912 S  0.3  0.2   2:49.93 litespeed (lshttpd)
    
    I can't udnerstand why is it lagging sometimes. any suggestions?
  4. webizen

    webizen New Member

    load is very low. what's your server environment (cpu, os, disk, uplink, control panel like cpanel, etc)? for cpanel, make sure matching php gets built in lsws.

    also check real-time stats in Admin Console (Actions => Real-Time Stats) and see if column 'EAProc WaitQ' stays with '0'(zero) when you experience slowness.
  5. nikoc1337

    nikoc1337 New Member

    It actually seems to be good for now. Im running webmin control panel.

    Processor: Xeon E3-1230 3.2GHz Memory: 8GB RAM
    Primary HD: 2.0TB SATA HDD Secondary HD: None
    1GBIT (Upgraded yesterday from 100mbit)

    Im trying to understand the difference between licenses on enterprise.
    I mean what if i get 1 CPU license, 2 or 4.
  6. webizen

    webizen New Member

Share This Page