Compatible mod_security rules

Discussion in 'General' started by alexvicol, Nov 17, 2012.

  1. alexvicol

    alexvicol New Member

    Hello,
    Can you ( litespeed tech ) provide a ruleset of the mod_security that are 100% compatible with lsws?
    For exemple: a striped down version of the atomic corp delayed ruleset ( http://updates.atomicorp.com/channels/rules/delayed/modsec-2.5-free-latest.tar.gz ), just that ones that lsws executes ok and suports.

    Now if I want to use the atomic corp rules, lsws just brakes , creates core dumps , etc. An old ruleset from february works ok , it doesn't brake lsws but it adds significant load time to every page, so I'm looking just for the rules that really work.

    Thanks.
  2. alexvicol

    alexvicol New Member

    Hello LiteSpeed,
    Any news on this?
  3. alexvicol

    alexvicol New Member

    Hello,

    Ok, as I understand all the support that litespeed is offering is by forum.
    Can I get some?

    I'm paying 32$ per license and no support?
  4. webizen

    webizen New Member

  5. alexvicol

    alexvicol New Member

    Hello,
    Already read that.
    It says the lsws try to be 100% compatible with gotroot rules, but I need a set of rules that are 100% compatible , one set of gotroot rules that has the incompatible rules deleted .
    If I use the gotroot rules lsws will restart every X min/hours because of one ore more mod_security rules that is incompatible with lsws.
    I can't delete myself this rules with try and error in production mode , that's why I as you ( LiteSpeed Staff ) to provide a set of rules 100% compatible with the stable version of lsws .
  6. webizen

    webizen New Member

    As pointed out in the wiki, lsws does NOT cover less important or rarely used rules. So pls send the rules in question that trigger lsws to restart for review.
  7. alexvicol

    alexvicol New Member

    Hello,
    I didn't said it's not compatible with important rules but I cannot activate the rules and note every rule that breaks lsws because the server is in production and would make the website behave abnormally.
    That's why I've asked a set of rules from you.
  8. NiteWave

    NiteWave Administrator

    those unsupported rules should not break lsws since they'll be ignored.
    if some rules really break lsws, we'd like to know, and fix it. in such case, we can co-operate to find the solution. for example, we can login your server, identify if it's gotroot rules break lsws and if so, which rule, and apply the fix.
  9. alexvicol

    alexvicol New Member

    Hello,
    If I use the latest rules as soon as I upload them and enable them , as soon as I restart lsws to use the mod_security rules , lsws just keeps crashing every second and restarts.
    Where can I send the core files created by lsws when it restarts?
  10. NiteWave

    NiteWave Administrator

    please report to bug@ ..., if you've not done it yet.

Share This Page