Configuration

Discussion in 'Install/Configuration' started by freeballt, Jul 15, 2011.

  1. freeballt

    freeballt New Member

    Are there any guides for optimal Litespeed settings? Perhaps a tool to set our configuration based on our system specs? I am running a server with 2x quad cores and 32 gigs of ram and my site randomly gets 503's as well as random lag spikes.

    2011-07-15 17:23:14.727 [NOTICE] [189.46.144.216:2710-0#] POST request in process stage, fail with 503
    2011-07-15 17:23:14.727 [NOTICE] [189.46.144.216:2710-0#] oops! 503 Service Unavailable
  2. webizen

    webizen New Member

    do you have other log entries around the lines in question that may provide more info? it could be php crash due to code issue, etc.
  3. freeballt

    freeballt New Member

    In that case, is there a log that dumps out where the errors are occurring? I have a vbullletin forum with a number of plugins and I have no idea where to look. The logs are useless, and these spikes are reoccurring. When they do occur it seems like there are 100's of lsphp5 instances, and I really would like to get to the bottom of this.
  4. freeballt

    freeballt New Member

    In addition, I am getting a TON of these in my logs:
    HttpExtConnector state: 8, request body sent: 0, response body size: 0, response body sent:0, left in buffer: 0, attempts: 0.
  5. webizen

    webizen New Member

    It should be /usr/local/lsws/logs/error.log or /usr/local/apache/logs/error_log (for cpanel).

    Are you saying 503 error is due to spikes of requests? If so, you can increase process soft/hard limit in lsphp5 (Admin CP -> Configuration -> Server -> External App).

    Last edited: Aug 1, 2011

Share This Page