Content gzipping not working after upgrade to 3.3-ent

Discussion in 'Bug Reports' started by subBlue, Nov 20, 2007.

  1. subBlue

    subBlue New Member

    I've just upgraded from 3.2.4-ent to 3.3-ent and now I've noticed (via the ySlow firebug plugin) that the gzipping of css and js files is no longer working. The actual HTML file is being gzipped.
    My configuration hasn't changed since the upgrade. The compressible types are set to: text/*, application/x-javascript
    If I roll back to 3.2.4 it still doesn't deliver the gzipped css and JS.

    Any suggestions?
    The site I'm looking at is www.tictocfamily.com
  2. mistwang

    mistwang LiteSpeed Staff

    Are you using 3.2.4 or 3.3 now?
  3. mistwang

    mistwang LiteSpeed Staff

  4. subBlue

    subBlue New Member

    I've installed LS 3.3.1-ent but it still isn't GZipping the CSS and JS :confused:
  5. mistwang

    mistwang LiteSpeed Staff

    try changing the gzip working directory under the tuning page, by default /tmp/lshttpd/swap is used, may not have enough space left, or the /tmp partition has been mounted with "noexec".
  6. subBlue

    subBlue New Member

    Only 3% of the /tmp partition is being used, but I tried clearing the swap directory anyway and also tried setting the swap directory to be on a different partition. Still no joy.

    My server is running as nobody:nobody and the vhosts are setup as ExtApp Set UID Mode: DocRoot UID and ExtApp Chroot Mode: Same as server.

    I'm not sure whether or not the /tmp partition has been mounted with "noexec" or how to change it if it has :/
  7. mistwang

    mistwang LiteSpeed Staff

    Make sure the that directory is writable for "nobody" user.
  8. subBlue

    subBlue New Member

    It is, I can clear the swap directory, restart LS and see the cache files being created again.
  9. mistwang

    mistwang LiteSpeed Staff

    OK, the bug has been identified, the fix will be in 3.3.1 release due in this week.

Share This Page