directadmin usage log

Discussion in 'Apache Migration/Compatibility' started by felosi, Aug 28, 2007.

  1. felosi

    felosi New Member

    I tried to setup awstats on a domain today but the logs it was reading was empty, and when I checked directadmin the access and error_logs was empty as well. The strange thing is that webalizer is working and logging stats just fine I just cant find where its getting those stats.

    Does lsws log anywhere besides the lsws directory for apache logs in directadmin?
  2. mistwang

    mistwang LiteSpeed Staff

    LSWS log to the same directory where Apache does. The path should be in the httpd.conf or the vhost configuration file.
  3. felosi

    felosi New Member

    well Ive seriously tried everything. I been trying to find out how to block this gigaloader.com and I was testing it while tailing any possible log I can think of and nothing ever showed up. Just assorted stuff.

    Anyway, On my directadmin servers one time on install I imported apache config right there, same on cpanel server, and when I did it imported all the vhosts. Then I could control my vhosts from within the litespeed admin, a real cool feature. But I think it was causing problems and moving real slow and on the wiki it says not to do it, so when I installed and reinstalled on my directadmin servers the vhosts never imported.

    If I was to reinstall and import apache config then would it import the vhosts right and do ok? Id really like to get that working on cpanel too. That feature there would be gold. I know I could have used it many times while certain clients were under attack.

    Or if I could just add single clients to that vhost config that would be nice. Ive tried everywhere I can think of and never got it to work. Ill keep on trying. Im still a lil baffled about the error logs in directadmin. I cant find why they are not logging or partially logging.
  4. felosi

    felosi New Member

    hey I noticed in litespeed admin for the vps this
    Loading configuration from /opt/lsws/conf/httpd_config.xml ...

    So may not be importing the apache config all the way, Ill look through my other servers and see if it does the same
  5. mistwang

    mistwang LiteSpeed Staff

    From our directadmin generated sample httpd.conf, the access log files are strored as /var/log/httpd/domains/<domain_name>.log.

    httpd_config.xml is the main configuration file of LSWS, it is always loaded.
  6. felosi

    felosi New Member

    Yeah they are there. Somehow I got it working on my dedicated directadmin server, still trying with vps..
    Im sure its something Ive messed up or overlooked along the way.

    on the directadmin install per the wiki is it supposed to import the vhosts into litespeed admin? I remember one time it done that for me but Im pretty sure I loaded apache config on install.

    Im gonna be working on importing a few clients on my cpanel server as well. Ill figure it out.

    Thanks for your help mistwang.
  7. mistwang

    mistwang LiteSpeed Staff

    User "apache" needs write permission to directory /var/log/httpd/domains/.

    No, you should not import Apache vhosts into litespeed admin if you plan to use LiteSpeed with hosting control panels, just let LiteSpeed read httpd.conf, all vhosts are still managed by the control panel.

Share This Page