Do you plan to issue a release working with Rack 1.0.1 ?

Discussion in 'Ruby/Rails' started by thbar, Jan 29, 2010.

  1. thbar

    thbar New Member

    Hello,

    after rereading this thread, I believe starting from Rails 2.3.5 (which apparently requires Rack 1.0.1), it won't be possible to run Rails on LiteSpeed.

    Am I right ?

    If so, do you have plans to publish a new release of either ruby-lsapi or the server itself that would make this work out of the box ?

    Any hint will be most welcome

    thanks for your support

    -- Thibaut
  2. mistwang

    mistwang LiteSpeed Staff

    Just patch the rack source code as described in that thread to make rack work properly.
    rack code is not maintained by LiteSpeed staff, we will work with rack team to resolve it for future releases.
  3. thbar

    thbar New Member

    Hello,

    thanks for your reply. Yes that's what I did in the end - I unpacked rack 1.0.0.

    I was just concerned about knowing if you were planning to keep supporting Rails (ie 2.3.5 + rack 1.0.1) in the future!

    -- Thibaut

Share This Page