Domain Allocation Not working after Installation

Discussion in 'Install/Configuration' started by Cool-R, Nov 19, 2010.

  1. Cool-R

    Cool-R New Member

    Hello,

    I've Installed Kloxo & Configured everything.

    Pointed my Domain to IP using "A" Record. Everything went fine.

    Created a User on Kloxo, The website resolved & I deleted everything & it was fine.

    Installed Litespeed server. Stopped Apache while Installation & Entered port 80 as default litespeed port.

    Now here comes the thing. When I go to the IP I get Litespeed successful page.(That is fine).

    But When I go to the domain. I get the same thing(litespeed page). I created a dir & I get

    Code:
    Request Page Not Found
    This is a customized error page for missing pages.
    After Installation, I wasn't able to make my domain work with FTP.

    Do I need to do any adjustments to my litespeed?

    Please assist.
  2. webizen

    webizen New Member

    Unlike other web servers, LiteSpeed web server (LSWS) does not have a default web site. Every web site is configured as a virtual host even only one web site is hosted. LSWS comes with a default vhost which docroot is /path/to/lsws/DEFAULT/html. If you have not yet setup a vhost for Kloxo, everything is referring to the default vhost.

    Please refer to this article for details http://litespeedtech.com/docs/webserver/config/concepts/

    To have LSWS listen on Kloxo domain, setup a vhost for Kloxo (with correct docroot path, etc) and map it with the listener on port 80. Or point default vhost docroot to Kloxo.
  3. Cool-R

    Cool-R New Member

    I'm really unsure how I would do this. I don't care about litespeed page but I'd be concerned if my domain isn't resolving to my FTP account.

    Could you please let me know how'd I do that?

    I have been playing games with Litespeed and this would be my final step before I use litespeed. Help would be really appreciated.

    Thanks for all your help mate.
  4. webizen

    webizen New Member

    LSWS comes with a default vhost (console->configuration->virtual hosts->Example). Its docroot is at $VH_ROOT/html/ (General tab) which usually is /path/to/lsws/DEFAULT/html/ ($SERVER_ROOT/DEFAULT/html). The easy way to have lsws answer kloxo is: change the default vhost docroot to /path/to/kloxo/docroot. This is what I meant "point default vhost docroot to Kloxo." If you only serve one domain, this is the way to go.

    The 2nd option is create a dedicated vhost for kloxo using the admin console (console->configuration->virtual hosts-> add). You may create a vhost from vhost template (http://www.litespeedtech.com/support/wiki/doku.php?id=litespeed:wiki:template). After that, you need to add that vhost to listener mappings (console -> configuration -> listeners -> Default -> Virtual Host Mappings -> add). This is needed if you want to serve multiple domains (with their respective docroots).
    Last edited: Nov 23, 2010
  5. Cool-R

    Cool-R New Member

    Hello,

    Thanks for the response mate.

    I've followed this,

    http://www.trentchallis.com/installing-litespeed-on-kloxo/

    Is this the same as what you've suggested? (Except editing the kloxo Virtual hosts?)

    Am I now using Lsws? Do I still have to make vhost listen mappings?

    I'm confused here, Help would be appreciated.

    EDIT:

    I have tried to delete the files & I get Apache default webpage. But when I just go to a random location like Domain.com/TEST I get "Powered by litespeed server"

    Is this just a VHost template or I'm still using Apache? (Since Apache Configuration is Turned ON in the tutorial)?

    I've followed the guide since, I was quite confused by the process that's all.
    Last edited: Nov 29, 2010
  6. webizen

    webizen New Member

    Is the Apache default webpage showing "This is the Kloxo Default Page"? If so, then you follow the guide (for installing lsws on kloxo) right and litespeed IS already serving web server for Kloxo.

    You can also verify using the following shell command:
    Code:
    # netstat -ntpl | grep :80
    tcp        0      0 0.0.0.0:80                  0.0.0.0:*                   LISTEN      xxxxx/litespeed (ls 
    # 
    Then your problem becomes: where is the document root for the default server and domain.com or how to find them?

    Default server info is in /etc/httpd/conf/kloxo/default.conf
    Domain.com info (DocumentRoot /home/admin/domain.com/) in file /home/httpd/domain.com/conf/kloxo.domain.com which is referred in the main virtualhost config file /etc/httpd/conf/kloxo/virtualhost.conf
    BTW, what version of Litespeed are you using? Keep in mind that the free version only can take up to 5 vhosts (domains) from Apache config. So if you are using the free version and you have more than 5 domains setup in Kloxo, it is possible the domain you tested did not get picked up by litespeed. To see what domains get picked up, log into litespeed web admin console (http://ip_to_server:7080) -> Actions tab -> check Virtual Host Mappings.
    Last edited: Nov 30, 2010
  7. Cool-R

    Cool-R New Member

    Well, I got this.

    I can presume I am running on lsws right?

    Also, I've used apache config.(from that tutorial) (Sorry, The tutorial isn't displaying normally but got it through Google Cache).

    This means, LSWS uses apache settings, but the server running in the background is lsws right?

    Thanks for your help. Finally, I'm able to sort things out. (I hope)
    Last edited: Nov 30, 2010
  8. mistwang

    mistwang LiteSpeed Staff

    You use LSWS with Apache httpd.conf, you should remove the listener and the vhost from web console. everything is configured through httpd.conf.
  9. Cool-R

    Cool-R New Member

    Alright, If I remove them Does this mean, I'm good with lsws? I mean, I'm completely running lsws right?

    Does it mean I'm still Apache? Or Lsws? I'm quite confused. Sorry, but I'm new to lsws & I have little knowledge in linux.
  10. webizen

    webizen New Member

    You are NOT running Apache. You are running LSWS with most configurations through httpd.conf (Apache config).

Share This Page