eAccelerator help! How to install it, php in web admin console

Discussion in 'PHP' started by rowebil, Jun 5, 2009.

  1. rowebil

    rowebil New Member

    I compile php 5.2.8 within litespeed console then i check if eaccelerator is loaded and it's not.
    How do I compile php for eaccel? disable cli or something like that?

    Provide steps.

    Here is my compile i used last time.

    --with-mysqli --with-zlib --with-gd --enable-shmop --enable-track-vars --enable-sockets --enable-sysvsem --enable-sysvshm --enable-magic-quotes --enable-mbstring --with-iconv --with-mysql --with-litespeed --with-config-file-path=/opt/lsws/configs --with-mcrypt --disable-posix-threads --enable-dynamic-loading --enable-eaccelerator=shared --disable-cli --disable-cgi

    Is it right?
  2. MindTooth

    MindTooth New Member

    Could you try to compile it once more. And add the code that get pasted at the end into your php.ini file.

    extension=eaccelerator.so
    .....
    ....

    :)
  3. rowebil

    rowebil New Member

    Still nothing. I really want to get it working because everyone says it makes scripts go faster. :'(
  4. auser

    auser Super Moderator

    run www.yourdomain.com/phpinfo.php

    to find out the right php.ini from
    "Configuration File (php.ini) Path"

    then made the change as MindTooth mentioned.
  5. MindTooth

    MindTooth New Member

    I think you can run this is in a shell:
    Code:
    php -info | less
    With this you can see all the info regarding PHP.

    Birger :)
  6. rowebil

    rowebil New Member

    I recompiled last night with Suhosin patch. I put suhosin.so at the end of the config file. I now see in phpinfo.php that suhosin is enabled.
    So, it must be working. But how come eAccelerator isn't working?

    Does eaccelerator have to be in the beginning of the php.ini file?
  7. rowebil

    rowebil New Member

    billy@server1 ~ $ /opt/lsws/fcgi-bin/lsphp5
    Failed loading /usr/local/Zend/lib/: /usr/local/Zend/lib/: cannot read file data: Is a directory
    PHP Warning: PHP Startup: Unable to load dynamic library './php_mcrypt.dll' - ./php_mcrypt.dll: cannot open shared object file: No such file or directory in Unknown on line 0PHP Warning: PHP Startup: Unable to load dynamic library './eaccelerator.so' - ./eaccelerator.so: cannot open shared object file: No such file or directory in Unknown on line 0PHP Warning: PHP Startup: Unable to load dynamic library './eaccelerator.so' - ./eaccelerator.so: cannot open shared object file: No such file or directory in Unknown on line 0^C
  8. rowebil

    rowebil New Member

    Yayy! I got it working! :)

    I commented out extension dir, then found the extension_dir in my phpinfo
    then found every instance of eaccelerator.so on my drive, then put it in that extension_dir :)
  9. brrr

    brrr New Member

    Could you quote the full options you finally used to successfully compile?

Share This Page