eaccelerator shared memory

Discussion in 'Install/Configuration' started by JFK, Jun 20, 2007.

  1. JFK

    JFK New Member

    Hello.
    How can I enable shared-memory for eaccelerator and lsapi php? I need eaccelerator_put and eaccelerator_get functions but now they are unavailable. According to eaccelerator manual it means that i haven't enabled --with-shared-memory flag but according to litespeed manulal this flag is enabled in binary downloaded by enable_phpa script. I've searched this forum and found that I should set instances to 1 and PHP_LSAPI_CHILDREN same as Max Connections (now both set to 20). But these settings did not helped.
    Eaccelerator part of my php.ini:
    Code:
    eAccelerator support	enabled
    Version 	0.9.5 
    Caching Enabled 	true 
    Optimizer Enabled 	false 
    Memory Size 	16,777,180 Bytes 
    Memory Available 	16,058,432 Bytes 
    Memory Allocated 	718,748 Bytes 
    Cached Scripts 	11 
    Removed Scripts 	0 
    Cached Keys 	0 
    
    Directive	Local Value	Master Value
    eaccelerator.allowed_admin_path	no value	no value
    eaccelerator.cache_dir	/tmp/eaccelerator	/tmp/eaccelerator
    eaccelerator.check_mtime	1	1
    eaccelerator.compress	1	1
    eaccelerator.compress_level	9	9
    eaccelerator.debug	0	0
    eaccelerator.enable	1	1
    eaccelerator.filter	no value	no value
    eaccelerator.log_file	no value	no value
    eaccelerator.name_space	no value	no value
    eaccelerator.optimizer	0	0
    eaccelerator.shm_max	0	0
    eaccelerator.shm_only	0	0
    eaccelerator.shm_prune_period	0	0
    eaccelerator.shm_size	16	16
    eaccelerator.shm_ttl	0	0
    
    What else I can do?
    Thanks in advance and sorry for my poor English.
    --
    Jakub Kasica
  2. mistwang

    mistwang LiteSpeed Staff

    The configuration option to enable it is --with-eaccelerator-shared-memory, our current binary was not built with that option, you need to build your own.

Share This Page