Eaccelerator using /dev/shm as cache dir

Discussion in 'General' started by ezpnet-ss, May 14, 2009.

  1. ezpnet-ss

    ezpnet-ss New Member

    I saw this tip posted by George buried in another thread. I thought it deserved it's own thread where we can share our experiences with this tip.

  2. ezpnet-ss

    ezpnet-ss New Member

    I see someone had an issue getting this working:

    We had the same problem. What fixed it for us - and I still don't know why - is changing one variable and nothing else:

    ----
    ;eaccelerator.shm_size="128"
    eaccelerator.shm_size="16"
    -----

    Anyone have any ideas? The test server we are working on has 8gb of ram and over 4gb free for us, so I'd like to get this value higher to see if we can cache more...

    anewday, did you get this to work?
  3. anewday

    anewday Moderator

    I assume it's working as I see files created in /dev/shm/lswsphp4eacc
  4. UWH-David

    UWH-David New Member

    I suspect your are hitting your kernel max. Check out

    http://eaccelerator.net/wiki/Settings and kernel.shmmax = value

    setting it to 128 should allow you to increase eaccelerator to 64 + for example.

Share This Page