Enable access log

Discussion in 'Install/Configuration' started by vkulov, Nov 24, 2010.

  1. vkulov

    vkulov New Member

    Really guys your documentation is out of this world. Can you reference me a page on your doc where you mention anything about XML. After all your config files are XML but the XML file structure is nowhere to be found :(

    I want the simplest thing - enable access logs on a virtual host or even on the whole server, anything...

    I see in your docs that I need to use "Log Control" but that's not an XML tag. is it <LogControl> tag? And where do I put it? In the vhost file or in the main config. And what is the surrounding XML structure around a

    I've got the access logs working only if I use an apache config file.
    I want it to work using the litespeed xml config file.

    I have this in httpd_config.xml

    <logging>
    <log>
    <fileName>$SERVER_ROOT/logs/error.log</fileName>
    <logLevel>DEBUG</logLevel>
    <debugLevel>0</debugLevel>
    <rollingSize>10M</rollingSize>
    <enableStderrLog>1</enableStderrLog>
    </log>
    <accessLog>
    <fileName>$SERVER_ROOT/logs/access.log</fileName>
    <rollingSize>10M</rollingSize>
    <keepDays>30</keepDays>
    <compressArchive>0</compressArchive>
    </accessLog>
    </logging>


    Error log is working fine. What do I need to do to actually start the access log???
  2. NiteWave

    NiteWave Administrator

  3. vkulov

    vkulov New Member

    I am aware of this.

    There is an Enable stderr Log option but there is no Enable Access Log option.

    So how do I enable it?

    How come the error log is working and access log is not?
    Last edited: Nov 24, 2010
  4. NiteWave

    NiteWave Administrator

    select 1 virtual host, then
    Log->Access Log

Share This Page