External processor is not available error

Discussion in 'General' started by semprot, Nov 2, 2013.

  1. semprot

    semprot Member

    On 31st october and just now (2nd november) my CPU load was dropped to nearly zero. Seems traffic was not handled by server at all.

    On 31st october i restarted mysql & httpd, and it was fixed, at that time i didn't know which one that fixed my problem. restarting mysql / httpd.

    Now on 2nd november, when i restarted mysql, nothing happened. When i restarted httpd from WHM, everything back to normal. So it is the web server problem.

    Last lsws config change that i had was (30th october) :
    lsws > server > connections > max connections > changed from 2000 to 4000

    Do you think that caused the error? Now i have reverted it back to 2000

    After rebooting the lsws recently on lsws log i see lot of these lines.

    Code:
    2013-11-02 13:38:51.081	INFO	[180.214.233.37:4169-0#APVH_mydomain.com] External processor is not available.
    2013-11-02 13:38:51.081	INFO	[180.214.233.37:4169-0#APVH_mydomain.com] abort request..., code: 4
    2013-11-02 13:38:51.585	INFO	[114.79.28.89:9868-0#APVH_mydomain.com] Connection idle time: 121 while in state: 5 watching for event: 25,close!
    2013-11-02 13:38:51.585	NOTICE	[114.79.28.89:9868-0#APVH_mydomain.com] Content len: 0, Request line: 'GET /showthread.php/892019 HTTP/1.1'
    2013-11-02 13:38:51.585	INFO	[114.79.28.89:9868-0#APVH_mydomain.com] HttpExtConnector state: 0, request body sent: 0, response body size: 0, response body sent:0, left in buffer: 0, attempts: 0.
    2013-11-02 13:38:51.585	INFO	[114.79.28.89:9868-0#APVH_mydomain.com] External processor is not available.
    2013-11-02 13:38:51.585	INFO	[114.79.28.89:9868-0#APVH_mydomain.com] abort request..., code: 4
    2013-11-02 13:38:52.291	INFO	[120.168.0.198:52115-0#APVH_mydomain.com] Connection idle time: 121 while in state: 5 watching for event: 25,close
    
    Thank you
  2. NiteWave

    NiteWave Administrator

    this may relate to this setting:
    lsws admin console->Server->Tuning->Connection Timeout (secs):default is 300, looks your setting is 120. right?
  3. semprot

    semprot Member

    yes, you are correct. however i have downgraded php 5.4 to 5.3, do you think this problem will dissapear because of that?

    Thank you.
  4. NiteWave

    NiteWave Administrator

    most likely, if the root cause is php 5.4 not compatible well with APC.

    you can search the log if it still exist after switching to php 5.3
  5. semprot

    semprot Member

    Now is my peak hour and everything runs way faster than my peak hour on previous day :)
    i think it's the result of combination of downgrading from php 5.4 > 5.3, change on the APC config, and little bit increase on litespeed memory soft & hard limit.

    Here is my APC config just in case anyone wants to try.
    Code:
    apc.cache_by_default	1
    apc.canonicalize	1
    apc.coredump_unmap	0
    apc.enable_cli	0
    apc.enabled	1
    apc.file_md5	0
    apc.file_update_protection	2
    apc.filters	
    apc.gc_ttl	3600
    apc.include_once_override	0
    apc.lazy_classes	0
    apc.lazy_functions	0
    apc.max_file_size	20M
    apc.mmap_file_mask	/home/apc_temp/apc.xxxxx
    apc.num_files_hint	0
    apc.preload_path	
    apc.report_autofilter	0
    apc.rfc1867	0
    apc.rfc1867_freq	0
    apc.rfc1867_name	APC_UPLOAD_PROGRESS
    apc.rfc1867_prefix	upload_
    apc.rfc1867_ttl	3600
    apc.serializer	default
    apc.shm_segments	1
    apc.shm_size	5144M
    apc.slam_defense	0
    apc.stat	0
    apc.stat_ctime	0
    apc.ttl	0
    apc.use_request_time	1
    apc.user_entries_hint	0
    apc.user_ttl	7200
    apc.write_lock	1
    
  6. NiteWave

    NiteWave Administrator

Share This Page