ffmpeg-php help. ffmpeg.so not loaded

Discussion in 'Install/Configuration' started by piper, Jun 20, 2008.

  1. piper

    piper New Member

    I'm trying to install ffmpeg-php on my litespeed server, ffmpeg is running fine and after compiling ffmpeg-php the ffmpeg.so was created in /usr/local/lib/php/extensions/no-debug-non-zts-20060613/

    My other modules are located in /opt/lsws/lsphp5/lib/php/extensions/no-debug-non-zts-20060613

    so i copied it over and add

    extension = ffmpeg.so to my php.ini

    But it still doesnt work, any pointer? I also tried to compile php with --with-ffmpeg flag.

    Please assist.

    Running latest version of Litespeed enterprise/RHEL5.2
  2. mistwang

    mistwang LiteSpeed Staff

    Try
    /opt/lsws/fcgi-bin/lsphp5 -i

    from command line and fix all errors, make sure ffmpeg module apear in the output.
  3. piper

    piper New Member

    its not showing at all, how can i see if ffmpeg.so is loaded properly?
  4. mistwang

    mistwang LiteSpeed Staff

    check the php.ini used from "lsphp5 -i", make sure php.ini has been configured to load ffmpeg.so .
  5. piper

    piper New Member

    No luck with it, the output does not show ffmpeg.so was loaded

    here is what i have on the php.ini (i checked ffmpeg.so is on the same folder of apc.so and suhosin.so)
    APC and Suhosin is loaded and shown on phpinfo

    extension_dir = /opt/lsws/lsphp5/lib/php/extensions/no-debug-non-zts-20060613
    extension = ffmpeg.so
    extension= suhosin.so
    extension = apc.so
    apc.shm_size = 32
    apc.enabled=1
    apc.shm_segments=1
    apc.optimization=0
    apc.ttl=7200
    apc.user_ttl=7200
    apc.num_files_hint=1024
    apc.mmap_file_mask=/tmp/apc.XXXXXX
    apc.enable_cli=1
    apc.filters = wp-cache-config,rebuild_smp

    All apps compiled correctly. I can run ffmpeg from command line, it just ffmpeg.so (ffmpeg-php) does not load)
    Last edited: Jun 20, 2008
  6. mistwang

    mistwang LiteSpeed Staff

    There should be an error at the beginning of output of "lsphp5 -i", also the php.ini used by lsphp5 should be listed on phpinfo, you should double check it reference to the right one.

Share This Page