GD Library

Discussion in 'Install/Configuration' started by .Bob, Aug 22, 2008.

  1. .Bob

    .Bob New Member

    Hi,

    I am currently running CentOS with the latest version of Litespeed & PHP 5.


    Well here is the problem. I am trying to get GD library too work. I have compiled PHP with the --with-gd flag (using litespeed's admin panel "Compile PHP" interface) and still no go. Things such as captchas (image verifications) for forums will not load. I dont know whats wrong.

    Any suggestions on how to go about fixing this?


    Thanks,
    Bob
  2. mistwang

    mistwang LiteSpeed Staff

    You may need to include png, jpeg and freetype2 support when you build the PHP. Check stderr.log and error.log for related errors.
  3. .Bob

    .Bob New Member

    Ah yeah that was it. Had to manually install the libjpeg and libpng packages and recompile PHP with the --with-png-dir=/usr/local --with-zlib-dir=/usr --with-jpeg-dir=/usr/local flags and it worked. Too bad those arent included with the actual GD package its self.

    Thanks for your help.
    Bob

Share This Page