Help! I cannot start litespeed from commandline!

Discussion in 'Install/Configuration' started by DavidPesta, Apr 12, 2007.

  1. DavidPesta

    DavidPesta New Member

    Good morning, I have run into something of an emergency.

    I really need to brush up more on how this system works, it is extremely important that I get this server up again ASAP!

    All I did was set the admin listener Secure to 'Yes' and on graceful restart, it brought the whole webserver down.

    [root@plain /]# /usr/local/lsws/bin/lswsctrl start
    [OK] License key verification passed! Software upgrade expires in 224 days.
    [OK] lshttpd: pid=10298.
    [root@plain /]# /usr/local/lsws/bin/lswsctrl reload
    [ERROR] lshttpd is not running.

    I cannot seem to find where the litespeed log file is!

    Please help!

    David
  2. DavidPesta

    DavidPesta New Member

    I found the log file:

    2007-04-12 12:12:34.721 [NOTICE] Your free software update will expire in 224 days.
    2007-04-12 12:12:34.721 [NOTICE] Loading LiteSpeed/3.0.1 Enterprise ...
    2007-04-12 12:12:34.722 [NOTICE] [ADMIN] server socket: 127.0.0.1:7078
    2007-04-12 12:12:34.722 [NOTICE] Loading configuration from /usr/local/lsws/conf/httpd_config.xml ...
    2007-04-12 12:12:34.724 [NOTICE] [config] chroot is disabled.
    2007-04-12 12:12:34.724 [INFO] old priority: 0, new priority: 0
    2007-04-12 12:12:34.724 [INFO] [config:server:basic] For better obscurity, server version number is hidden in the response header.
    2007-04-12 12:12:34.727 [ERROR] [config:admin:listener:adminListener] missing <certFile> in <listener>
    2007-04-12 12:12:34.727 [ERROR] [config:admin:listener] No listener is available for admin virtual host!
    2007-04-12 12:12:34.727 [ERROR] Fatal error in configuration, exit!


    This looks related to turning Secure to 'Yes' in the admin listener. Now I just need to figure out how to set it back without the web interface..

    If you could help me with this while I try to figure it out, that would be most helpful.

    Thanks!
    David
  3. DavidPesta

    DavidPesta New Member

    I am trying to find the config file to turn the admin listener Secure back to 'No' as this should fix it. I cannot seem to find the config file for this...still looking.

    Please let me know where that config file would be if you get this.

    Thanks!
    David
  4. DavidPesta

    DavidPesta New Member

    Ah ha! The config file was inside of the lsws/admin/conf/ and not the lsws/conf/

    Now I know for next time.

    30 minutes of down time is not too bad. All is good!

    David
  5. mistwang

    mistwang LiteSpeed Staff

    If you set "Secure" to "Yes", you need to specify SSL key and certificate as well.
  6. DavidPesta

    DavidPesta New Member

    I'll try that with my test server next time. :D

    Thanks!
    David

Share This Page