Help with Redmine (503 error)

Discussion in 'Ruby/Rails' started by bkonia, Apr 30, 2013.

  1. bkonia

    bkonia New Member

    I'm trying to get Redmine working with Litespeed, using the instructions on this page:

    http://www.litespeedtech.com/support/wiki/doku.php?id=litespeed_wiki:ruby_rails

    However, it's giving me a 503 error. I see the following in stderr.log:

    2013-04-30 13:15:16.822 [STDERR] /usr/local/lsws/fcgi-bin/RackRunner.rb:13:in `require': no such file to load -- rack (LoadError)
    2013-04-30 13:15:16.822 [STDERR] from /usr/local/lsws/fcgi-bin/RackRunner.rb:13

    I can confirm that the rack file does not exist in /usr/local/lsws/fcgi-bin/. I also notice that RackRunner.rb is referencing lsapi which does not exist in that directory either.
  2. Duplika

    Duplika New Member

    I wished we were able to make Redmine work out of the box, having an updated Ruby working with cPanel / Litespeed.

Share This Page