High Server Load at regular times

Discussion in 'General' started by iUnknown, May 10, 2009.

  1. iUnknown

    iUnknown New Member

    Hello,

    Every day now, the server load goes extremely high and makes the server go too slow to do anything on. This happens at two points during the day, and at around the same time. I can't figure out what it is, but look at what is using a hell of a lot of resources:

    [​IMG]

    Any ideas why this might be happening?
  2. mistwang

    mistwang LiteSpeed Staff

    check your cron job, if it happen every day around the same time, it must be some batch job use too much system resources, causes high memory usage or high I/O load.
  3. iUnknown

    iUnknown New Member

    I just looked through every single cron job (in /var/spool/cron) and none of them run anywhere near the times that it happens.

    However, I have noticed a ton of crond processes at these times, I overlooked them thinking that they might have been piling up due to the lag but realise how stupid that is now. I will investigate them further.

    Interesting thing is, it only happens when I have suexec enabled in litespeed? Everything runs perfectly on the server, but at these times everything seems to go crazy.
  4. iUnknown

    iUnknown New Member

    Hi,

    It must be some sort of issue with litespeed. The crond processes I noticed once was a one off as this has happened many more times with only one or two crond processes in sight, and very low down using little memory usage. lsphp processes seem to have a much higher CPU % during these times and stopping litespeed leads everything to recovery... lsphp processes are top of the list at this time when looking either in order of CPU usage and memory usage.
  5. anewday

    anewday Moderator

    Better to ask George to take a look at your server.
  6. mistwang

    mistwang LiteSpeed Staff

  7. iUnknown

    iUnknown New Member

    Sorry, I cannot find the variable under any tab of the configuration in the :7080 control panel...
  8. auser

    auser Super Moderator

    Mine is at
    Configuration->Server-->External App-->select lsphp5-->Max Idle Time

Share This Page