How does one configure a rack enabled app in litespeed?

Discussion in 'Ruby/Rails' started by Dru, Dec 11, 2008.

  1. Dru

    Dru New Member

    This has been bugging me for a while now and it's finally gotten to the point where I can't ignore it since I'm developing a rails app on edge rails which has recently ditched the cgi interface in favour of rack.

    I understand that rack already has support for litespeed but how do I actually configure litespeed to make the app work?

    Any post/guide on doing this would be most helpful.
  2. Dru

    Dru New Member

    Actually it seems there's still a cgi wrapper around rack (see this commit) for backward compatibility but having done a quick test deployment it doesn't seem to be working.

    Perhaps the lsapi could be modified to work with this, assuming the problem is actually the fault of lsapi?
  3. mistwang

    mistwang LiteSpeed Staff

    I am not that familiar with rack.

    For the lobster example comes with the rack package, you need to change the handler from WEBrick to LSWS in protectedlobster.rb

    Code:
    Rack::Handler::LSWS.run pretty_protected_lobster
    Then add an external application to LSWS and assign proper script handler and/or context handler.

    You can contact Adrian Madrid at our forum, he contribute the LSWS rack handler.
  4. Dru

    Dru New Member

    I'll have to give it a go later, I'm not optimistic I'll get it working though as I've had little luck in any of my previous attempts.

    Hopefully this can be simplified by the time rails 2.3 is out, which I gather could potentially be fairly soon given the rate development is going at currently.

Share This Page