how to install mod_expires?

Discussion in 'Install/Configuration' started by furimedia, Sep 17, 2008.

  1. furimedia

    furimedia New Member

    Hi

    How do I get mod_expires working with Litespeed?
  2. mistwang

    mistwang LiteSpeed Staff

    It should work.

    Just that you may need to define the MIME type in the server level MIME configuratin.
  3. furimedia

    furimedia New Member

    I'm sorry but could you care to explain a bit?
    I'm just trying to cache all the images/js/css files using this expires module.

    Thank you
  4. mistwang

    mistwang LiteSpeed Staff

  5. furimedia

    furimedia New Member

    Can I have this in my .htaccess?
    ExpiresDefault "access plus 1 year"

    Will litespeed pick that up?

    Also, if my js and css file path look like for instance:

    <script src="index.php?js=/a.js,/b.js,/c.js"></script>

    Will that be picked up by litespeed's default mime configuration?
  6. mistwang

    mistwang LiteSpeed Staff

    The expires header is only effective for static file, not for dynamically generated content, you need to add those headers in your PHP script.

Share This Page