.htaccess/htpasswd

Discussion in 'Install/Configuration' started by solmakous, Jul 23, 2004.

  1. solmakous

    solmakous New Member

    I have been trying to require authentication to a certain folder for my little website, and have been unable to. it just allows me access no problems :/

    in server configuration i have all three option checked, and none unchecked
    and no, i'm not connecting from 192.168.0.102, i'm connecting from 192.168.0.103
    Code:
    ErrorDocument 404 /error404.html
    ErrorDocument 401 /error404.html
    
    authtype Basic
    authname FU
    authuserfile /opt/lsws/DEFAULT/html/alliancewars/.htpasswd
    order deny,allow
    deny from all
    allow from 192.168.0.102
    require valid-user
    satisfy any
    
    this is the folder i wish to require authentication, I used
    Code:
     htpasswd -bcd .htpasswd $username $password 
    to create the .htpasswd file

    [/code]
  2. mistwang

    mistwang LiteSpeed Staff

  3. solmakous

    solmakous New Member

    thnaks for the info, next time i try your product i will try using it without the satisfy/errordocument directives, i guess it defaults to satisfy any? or satisfy all?

    yes, i had all thre boxes checked
  4. mistwang

    mistwang LiteSpeed Staff

    Satisfy all.
    We will investigate this issue when we are available.

    Thank you.
  5. mistwang

    mistwang LiteSpeed Staff

    The link given in earlier reply refers to the option "Enable Context Access Control" under "Security" tab of virtual host configuration, it must be set to "Yes".

    Make sure the permission of .htaccess and .htpasswd are correct.

    Our test shows that .htaccess works pretty well. :)

Share This Page