.htaccess not working

Discussion in 'Install/Configuration' started by sth, Oct 9, 2006.

  1. sth

    sth New Member

    when enabled htaccess in one dir, browser fails to authenticate and continue to prompt for password.

    I use a VHtemplates

    For every site I have a "stats" directory with a specific .htaccess where is specified the required user and a required group in order to view the dir content.

    If I use realm and context the user is autenticated but the problem is that I can specified "one user" for "one site" and with VHtemplates if I enable realm and context all the user in my password file are authenticated in every site.

    This is my .htaccess file:
    AuthUserFile /etc/httpusers/.users
    AuthGroupFile /etc/httpusers/.groups
    AuthName "Statistiche sito"
    AuthType Basic

    <limit GET>
    require user sth
    require group sth
    </limit>


    ---

    Thanks
    Alessandro
  2. xing

    xing LiteSpeed Staff

    For security reasons, the litespeed by default does not allow access to /etc/ folder.

    You can change it via "Server -> Security -> Access Denied Directories" in the web admin gui.
  3. mistwang

    mistwang LiteSpeed Staff

    /etc/ for password file probably is fine, fixed a bug related to authentication configuration in htaccess, fix will be in 2.2.3 release.

Share This Page