htaccess problem

Discussion in 'General' started by ElGato, Apr 10, 2009.

  1. ElGato

    ElGato New Member

    Hello.

    I have a problem with .htaccess files. It seems to LiteSpeed ignore any commands in it.

    There are two web-servers: Apache/1.3 and LiteSpeed 4.0.
    Htaccess on Apache works fine. And on LiteSpeed 3.3.24 WAS worked fine too.
    (problem appeared after upgrade from 3.3.24 to 4.0)

    I have switch on all "Override" values (see attached file) in LiteSpeed CP.
    Is there any other options with htaccess?


    I think there is may be some feature with how LiteSpeed work with symlink:
    I have symlink:
    htdocs -> /home/htdocs

    And there is a rule:
    Code:
    <Directory />
        AllowOverride None
    </Directory>
    
    <Directory "/htdocs">
        Options Includes SymLinksIfOwnerMatch ExecCgi MultiViews
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    
    I have tested web-servers with $_SERVER["DOCUMENT_ROOT"] variable.
    (I have created file and try to access it under Apache and LiteSpeed)
    The result is:
    Apache: /htdocs/.......
    LiteSpeed:/home/htdocs/..........

    I guess Apache ruled by second rule, and LiteSpeed by first rule??
    Does it can be a reason for my problem?


    For some reason, I can't modify these rules. Is there another solution for this problem?

    Thanks

    Attached Files:

  2. mistwang

    mistwang LiteSpeed Staff

    Please upgrade to 4.0.1, should be fixed.

Share This Page