In need of desperate help getting litespeed to run

Discussion in 'Install/Configuration' started by Doublethebacon, Mar 14, 2013.

  1. Doublethebacon

    Doublethebacon New Member

    I got license off third party site got it installed however it seems that it won't run with having apache I can't get it to run alone I've been missing with this for the second day.. I'd appreciate some type of direction to go

    Honestly If I known I needed collage degree in computer engineering to run litespeed I never would have gotten a license

    What is the port or does it run on the same port as apache ? (90% of examples out there don't say anything about that)
  2. webizen

    webizen New Member

    You got to have some basic knowledge to run Apache or LSWS. You can google it what the "http port" means. don't think you need college degree to understand it.

    Back to your issue, basically, you can not have both apache and lsws listen on http port (TCP port 80) at the same time. To work around it, do either of the below:

    1) Stop apache and have lsws listen on http port
    If you use cpanel, go to WHM=>plugins=>LiteSpeed Web Server=>Switch to LiteSpeed. That should do it.
    2) Have apache run on http port and lsws run on a different port (Offset port).
    If you use cpanel, go to WHM=>plugins=>LiteSpeed Web Server=>LiteSpeed Port Offset =>Change=> 2000. Then reststart LiteSpeed.
  3. Doublethebacon

    Doublethebacon New Member

    I'm beginning to think its the server it self simply cause neither apache or lite speed will work.

    The server has been crap time to find different forum thank you for your help I really appreciate it
  4. webizen

    webizen New Member

    You are welcome. Usually make sure Apache runs first before switch to LSWS. That will save you time getting LSWS works for you.
  5. Doublethebacon

    Doublethebacon New Member

    When I first got it it was working actually then today it seemed to stop working
  6. webizen

    webizen New Member

    Do you mean LSWS was working before but not now? How long have you run it? Is your license still valid? go to LSWS plugin => License Management => Check Status

    Or

    run below from command line to verify

  7. gdewey

    gdewey New Member

    Bacon you can see if its a port problem by changing LS from port 80 to any other and restart. If its start then there is another webserver running.

    to disable apache check for org.apache.httpd.plist file on any of this directories and remove it. then it wont start.

    ~/Library/LaunchAgents
    ~/Library/LaunchDaemons

    /Library/LaunchAgents
    /Library/LaunchDaemons


    (that is in mac, not sure if it applies to linux)
    /System/Library/LaunchAgents
    /System/Library/LaunchDaemons

Share This Page