Install on CentOS5.5, Plesk, need to work with vBulletin

Discussion in 'Install/Configuration' started by Alan_SP, Mar 31, 2011.

  1. Alan_SP

    Alan_SP New Member

    Ok, I installed standard version (you can see it from the name) using this commands:

    Code:
    cd /usr/local/src
    wget http://www.litespeedtech.com/packages/4.0/lsws-4.0.20-std-i386-linux.tar.gz
    tar xvfz lsws*
    cd lsws*
    ./install.sh
    From instructions explained here: http://www.litespeedtech.com/support/wiki/doku.php?id=litespeed_wiki:apache:plesk

    I left HTTP port at 8088.

    After that I went to compile PHP, used this config:

    Code:
    --prefix=/lsphp5   --with-litespeed   --with-libdir=lib  --disable-debug   --with-pic   --disable-rpath   --without-pear   --with-bz2 --with-config-file-scan-dir=/etc/litespeed/php.d --with-config-file-path=/etc/litespeed  --with-exec-dir=/usr/bin   --with-freetype-dir=/usr   --with-png-dir=/usr   --with-xpm-dir=/usr   --enable-gd-native-ttf   --without-gdbm   --with-t1lib=/usr   --with-gettext   --with-gmp   --with-iconv   --with-jpeg-dir=/usr   --with-openssl   --with-pcre=shared,/usr   --with-zlib   --with-layout=GNU   --enable-exif   --enable-ftp   --enable-magic-quotes   --enable-sockets   --enable-sysvsem   --enable-sysvshm   --enable-sysvmsg   --with-kerberos   --enable-ucd-snmp-hack   --enable-shmop   --enable-calendar   --without-mime-magic   --without-sqlite   --with-libxml-dir=/usr   --enable-xml   --with-system-tzdata   --enable-force-cgi-redirect   --enable-pcntl   --with-imap=shared   --with-imap-ssl   --enable-mbstring=shared   --enable-mbregex   --with-ncurses=shared   --with-gd=shared   --enable-bcmath=shared   --enable-dba=shared   --with-db4=/usr   --with-xmlrpc=shared   --with-ldap=shared   --with-ldap-sasl   --with-mysql=shared,/usr   --with-mysqli=shared,/usr/bin/mysql_config   --enable-dom=shared   --with-pgsql=shared   --enable-wddx=shared   --with-snmp=shared,/usr   --enable-soap=shared   --with-xsl=shared,/usr   --enable-xmlreader=shared   --enable-xmlwriter=shared   --with-curl=shared,/usr   --enable-fastcgi   --enable-pdo=shared   --with-pdo-odbc=shared,unixODBC,/usr   --with-pdo-mysql=shared,/usr   --with-pdo-pgsql=shared,/usr   --with-pdo-sqlite=shared,/usr   --with-pdo-dblib=shared,/usr   --enable-json=shared   --enable-zip=shared   --with-readline   --enable-dbase=shared   --with-pspell=shared   --with-mcrypt=shared,/usr   --with-mhash=shared,/usr   --with-tidy=shared,/usr   --with-mssql=shared,/usr   --enable-sysvmsg=shared   --enable-sysvshm=shared   --enable-sysvsem=shared   --enable-posix=shared   --with-unixODBC=shared,/usr 
    I included xcache, in custom config directories I put ini files for xcache and php.ini, with correct xcache.so path.

    When I check php with /usr/local/lsws/fcgi-bin/lsphp5 -v I see it runs with xcache and with -i I see correct settings from xcache.ini. So I think php is compiled correctly.

    Now, problem is, when I go to my sites URL with :2080 I don't see my site. When I go there without 2080 port, I see it, and when I check php version, it's 5.2.17 (I compiled for Litespeed latest 5.3.6).

    What happend and why, I don't know. Like it didn't collected information from Plesk configuration as it should did. Plesk is 10.0.1. This is my test server, I want to test it before I try it on my production server. What's happend, I really don't know. Test server works fine through URL (on Apache), LiteSpeed Admin console works fine, no problem there (at least I didn't see any).

    But something's wrong, it didn't replaced apache server for Plesk. It shows pages when you don't have anything there. I copied my web directory in /usr/local/lsws/DEFAULT/html, here files couldn't be executed, but their contents was shown when I pointed directly to them.

    Server's VPS, there's only my site, for my testing purposes. Anyway, I need it to be able to run vBulletin (v4), some perl (they need cgi-bin) and php scripts.
  2. Alan_SP

    Alan_SP New Member

    I just played with some options, it seems that directory of my site isn't imported and when I set it manually, Litespeed console says that directory is unreadable. :(
  3. NiteWave

    NiteWave Administrator

    1.
    #netstat -ntlp
    to check if litespeed is running

    2.try run litespeed on port 80 to see if it works:
    --- stop Apache, change Apache Port Offset to 0, restart LSWS, all hosted web sites are powered by LiteSpeed now.

    3. since not for shared hosting setup, try
    PHP suEXEC => No
  4. NiteWave

    NiteWave Administrator

    build php may have problem. for all option with "shared", need build additional .so as well. or remove all "shared", rebuild php again.
  5. Alan_SP

    Alan_SP New Member

    Litespeed is running. I stoped Apache, but there's still error. It opens default Apache page, but of course, servered with Litespeed. :(

    I'll try later with rebuilding php, and report what's going on.

    I don't know why, but it just doesn't show what I have in my htmldocs directory. :( Like it didn't imported all of Plesk configurations. :(
  6. webizen

    webizen New Member

    how many vhosts in plesk? keep in mind that standard lsws only takes 5 vhosts from apache config.
  7. Alan_SP

    Alan_SP New Member

    I have only one site (vhost), just for my site, I'm not in hosting my server to others.

    When I was installing, I didn't choose to have PHP installed right away, but I compiled it afterwards.

    These are errors I see when I go to web console:

    There's only this virtual host in settings:

    Example $SERVER_ROOT/DEFAULT/

    As I see it, for some reason process of importing my virtual host (as I have only one) didn't succeded. Any suggestions?

    I would probably try to reinstall it from the beginning, but do you have some suggestions, what should I try before? My test server is VPS, on Virtuozzo.

    Procesor GenuineIntel, Intel(R) Xeon(R)CPU E5520 @ 2.27GHz
    Version Parallels Plesk Panel v10.0.1_build109101029.17 os_CentOS 5
    OS Linux 2.6.18-028stab070.3
  8. mistwang

    mistwang LiteSpeed Staff

    Pleask create too many junk vhosts before your real vhost, so it wont work well with standard edition of LSWS due to the 5 vhosts limit.
    You need a VPS license or configure your vhost in LSWS natively.
  9. Alan_SP

    Alan_SP New Member

    How I create my real vhost manually? What should I delete from Plesk files and try automatic recognition by Litespeed, or what options I need to use in Litespeed?

    I could delete everything, it's my test server, but I need to know what exactley is junk vhost, as I'll have similar situation on my live server, but there I couldn't make mistake.

    For now I'm just testing Litespeed and after I'll buy license (2 processors or 4, I have dedicated server), if I'm satisfied how it all works together.
  10. mistwang

    mistwang LiteSpeed Staff

    your best option is to use our trial license on your test server and use it together with plesk.
    If you are satisfied, then purchase a license for your production server.
  11. Alan_SP

    Alan_SP New Member

    Yes, I could use trial license, but also I'd like to know what caused the problem and why. Obviously there's a lot of junk vhost, I need to know to recognize them and delete them. What are they? I have 5 files in /var/www/vhosts/mysite.com/conf directory. Are they the problematic config files?

    I removed old ones, left only most recent. What I do know?
  12. mistwang

    mistwang LiteSpeed Staff

    No, you should not remove any configuration, it may break plesk completely, even though those vhosts are pretty much useless.
    Get a trial, then reinstall lsws with PHP enabled.
  13. Alan_SP

    Alan_SP New Member

    Ok, I try that.
  14. Alan_SP

    Alan_SP New Member

    I just disabled apache configuration and then enabled it again. This is erros I have now:

    The last one is new...
  15. mistwang

    mistwang LiteSpeed Staff

    When you install LSWS, you have to have "PHP" enabled, otherwise, you will get that error, after installation, build PHP5 will get you going.

    You should run install.sh again and select reinstall.
  16. Alan_SP

    Alan_SP New Member

    That could be the reason for my problems. :(

    I had declined to have PHP installed at first, wanting to install it later (as i did). I'll try reinstall, accept PHP installed at start and after that compile latest version of PHP.

    I'll report here with results when I do that.
  17. Alan_SP

    Alan_SP New Member

    Ok, I reinstalled Litespeed, now I enabled php from the beginning and now some things work, some things don't. For example, it loads php 5.3.6 that I compiled from the last time (I now that because it uses directories I said to use for configuration files). But it doesn't start my vBulletin forum. And also reports too many vhosts.

    The problem, at least in some respect was not installing PHP from the start.
  18. NiteWave

    NiteWave Administrator

    if you only have one vhost, and mainly test vBulletion, suggest not to read httpd.conf which managed by plesk. that only increase the complexity.

    when install standard or trial litespeed, do not choose any control panel.

    after installation, create a virtual host in admin console for vBulletin, build lsphp5, install vBulletin -- the vBulletion should be up quickly.
  19. Alan_SP

    Alan_SP New Member

    Well, I must say that creating vhost for me it's too advanced a feat to take it. :)

    On the bright side, I just managed to get my vBulletin to work. I completly uninstalled Litespeed, manually removed all files left behind (mainly php files), then I installed it again, choose to have php from the start, compiled PHP (5.2.17, the same as with apache), but I left out this:

    --with-mysqli=shared,/usr/bin/mysql_config

    Probably this wrong mysqli configuration caused vBulletin not to start (I just had blank screen). :( Now it started, but I need to setup xcache (need to see where the xcache.so is).

    I need Plesk, as I use it for protecting directories and other things. I need to have it running with Litespeed.

    The biggest problem was not enabling PHP from the very start. You probably should stress it out, I thought that I would be able to compile PHP later, but it didn't went well enough.
  20. NiteWave

    NiteWave Administrator

    using --with-mysqli instead of --with-mysqli=shared,/usr/bin/mysql_config to get it easier.

    run phpinfo(), search "extension_dir", xcache.so should be there.

Share This Page