Issue with install (functions.sh line284)

Discussion in 'Install/Configuration' started by Robbieg, Jan 21, 2010.

  1. Robbieg

    Robbieg New Member

    Hey all,

    during install time, right after i enter my admin username and password i get the following error.

    ./functions.sh: line 284: /downloads/lsws-4.0.12/admin/fcgi-bin/admin_php: No such file or directory

    when i do a ls -alh /downloads/lsws-4.0.12/admin/fcgi-bin/admin_php i get
    -rwxrwxr-x 1 500 500 2.0M 2010-01-20 19:56 /downloads/lsws-4.0.12/admin/fcgi-bin/admin_php So the file is there.

    i'm running debian 5.0.3
  2. mistwang

    mistwang LiteSpeed Staff

    You uses the wrong package I think.
  3. Robbieg

    Robbieg New Member

    I have tried Linux (x86) and FreeBSD 4/5 (x86). They both give the same result.
  4. mistwang

    mistwang LiteSpeed Staff

    Maybe you should try x86_64 enterprise version if it is 64bit. Or, you need to install the 32bit compatible libraries. Google it.
  5. Robbieg

    Robbieg New Member

    i have done this several times over and have never had an issue like this before... but yet this is the latest version i have tried.

    when i try enterprise version i get [ERROR] Sorry, installation will abort without a valid license key. :)

    which libraries? I run plently of 32bit apps with no issues.
  6. mistwang

    mistwang LiteSpeed Staff

    You can apply a trial key to try the enterprise version.
    Just try

    ldd /downloads/lsws-4.0.12/admin/fcgi-bin/admin_php

    of the 32bit packet, then you need to install the missing libraries if you got that.
  7. Robbieg

    Robbieg New Member

    /downloads# ldd /downloads/lsws-4.0.12/admin/fcgi-bin/admin_php
    not a dynamic executable

Share This Page