Just converted from apache to litespeed

Discussion in 'General' started by dylan, Feb 27, 2008.

  1. dylan

    dylan New Member

    Ok so I converted from apache to litespeed.

    got a few questions.

    • In cPanel all the IP address's say MISSING
    • what is the location to the equivilant of the apache virtual host configuration file with litespeed.
    • My sites don't seem to be loading properly, one just loads the index, but won't load the sub folders?I then changed the index and it loads the cpanel success install page.
    • I'm confused as to what to how to set up new virtual hosts, theres listeners, templates.
    • What is the virtual host root?
  2. mistwang

    mistwang LiteSpeed Staff

    Have you followed the tutorial in our wiki?
    http://www.litespeedtech.com/support/wiki/doku.php?id=litespeed_wiki:apache:cpanel

    Litespeed just use all Apache configurations created by cPanel, it does not need special configuration file. With cPanel + litespeed, you just manage you server like what you used to do with Apache. everything is managed in WHM/cPanel.

    If you are using standard edition, the 5 vhost limit may have been hit. Enterprise edition should work fine.
  3. dylan

    dylan New Member

    I didn't install litespeed my host did, i'm going to get the VPS edition as i'm running a VPS then i'll see if that helps some of my issues.
  4. mistwang

    mistwang LiteSpeed Staff

    Just apply a trial key, then upgrade to Enterprise package, if it works well, you can go ahead with the VPS license.
  5. dylan

    dylan New Member

    Ok well I installed the standard version? Would I have to unistall to upgrade to the enterprise trial?
  6. mistwang

    mistwang LiteSpeed Staff

    No, just do a upgrade on top of it.
  7. dylan

    dylan New Member

    convenient my host decided to delete the old install files....

    Now what?

    Like install.sh isn't there?

    EDIT: Ok I upgraded. Still my sites don't load? I've got it set to pull from httpd.conf but it still wont work? What do I need to do?
    Last edited: Feb 27, 2008
  8. mistwang

    mistwang LiteSpeed Staff

    Please check LSWS error log, see if anything abnormal.
  9. dylan

    dylan New Member

    Nothing abnormal.
  10. mistwang

    mistwang LiteSpeed Staff

    Please PM me the login to LSWS admin console.

Share This Page