Litespeed cache settings

Discussion in 'LiteSpeed Cache' started by rosaline, Feb 2, 2012.

  1. rosaline

    rosaline New Member

    I use Litespeed Enterprise edition on our dedicated WHM panel.

    When I test my site with pingdom in this link :http://tools.pingdom.com/fpt/

    At request header's part: it says pragma: no-cache and cache-control is no-cache.. But response header's part is normal.

    I am sending screenshot of my cache settings in attachment. I have enabled cache on admin panel of Litespeed and configured some values as like:

    Expire default value is:A3600

    Expire by types: text/css=A604800, text/javascript=A604800, application/javascript=A604800, application/x-javascript=A604800, application/x-shockwave-flash=A604800, image/gif=A604800, image/jpg=A604800, image/jpeg=A604800, image/png=A604800, image/ico=A604800, image/icon=A604800

    Did I make any mistake from somewhere?

    Attached Files:

  2. NiteWave

    NiteWave Administrator

    the "Storage Path" must be set, now it's empty
  3. rosaline

    rosaline New Member

    how can I set it?
  4. webizen

    webizen New Member

    you need to create a directory for cache storage from command line first. Then fill storage path with it.

    1. mkdir /path/to/diskcache (i.e. /usr/local/lsws/diskcache)
    2. chown nobody.lsadm /path/to/diskcache (nobody is the webserver running user)
    3. chmod 770 /path/to/diskcache
    4. fill storage path (Admin CP => Configuration => Server => Cache => Storage Path) with '/path/to/diskcache' you just created.

  5. rosaline

    rosaline New Member

    I have created successfully, thank you very much for your helping..

    but still pingdom tester in this link: http://tools.pingdom.com/fpt/ says me pragma-no cache and cache-control: no-cache

    I have enabled cache from admin panel and set expire time 3600.Is it true?

    Also I want to decrease loading of images in my site what can I do for this issue?
  6. webizen

    webizen New Member

Share This Page