Litespeed not doing graceful restart.

Discussion in 'General' started by webzi, Mar 19, 2012.

  1. webzi

    webzi New Member

    Hi,

    I'm running litespeed with cPanel.

    When a user creates a new subdomain, the litespeed dosnt make graceful restart automaticly, why ?

    If I go to the litespeed interface and press graceful restart, the subdomain works just fine.

    Anyone got any ideas ?

    /C
  2. webizen

    webizen New Member

    please check /usr/local/cpanel/logs/safeapacherestart_log and /usr/local/lsws/logs/ap_cmd_param.log after adding/removing a domain. safeapacherestart_log shows when cPanel restart Apache. usually, cpanel wait up-to 1 minutes to apply new changes. Please make sure you do not disable Apache httpd service from WHM.
  3. jackwilliams

    jackwilliams New Member

    Hello,

    Even I am facing the same issue in one of my shared server. I tried to look the same in the log. But I am receiving the following error.
    =========
    # tail -f /usr/local/cpanel/logs/safeapacherestart_log
    [2012-06-04 17:10:37 +0800] info [safeapacherestart] Apache httpd is disabled, cannot be restarted
    [2012-06-04 17:28:23 +0800] info [safeapacherestart] Apache httpd is disabled, cannot be restarted
    =========

    Apache is disabled via /etc/apachedisable. I am not sure how to fix it. or how to disable apache via cPanel. Can you please elaborate?
  4. webizen

    webizen New Member

    To enable/disable httpd in cpanel:

    WHM/cPanel => Service Configuration => Service Manger => check/uncheck - Enabled httpd
    Last edited: Jun 4, 2012

Share This Page