Litespeed not Starting

Discussion in 'Apache Migration/Compatibility' started by hadrick, May 9, 2009.

  1. hadrick

    hadrick New Member

    I am using a trial version of Litespeed enterprise to see how better it performs, I couldn't get success in running litespeed perfectly in last 3 days yet. I have installed and tried to start and in the error log the following is getting logged:


    ================
    2009-05-09 13:38:38.604 [NOTICE] Loading LiteSpeed/4.0.2 Enterprise ...
    2009-05-09 13:38:38.806 [NOTICE] [ADMIN] server socket: uds://usr/local/lsws/admin/tmp/admin.sock.7324
    2009-05-09 13:38:38.806 [NOTICE] Loading configuration from /usr/local/lsws/conf/httpd_config.xml ...
    2009-05-09 13:38:38.807 [NOTICE] [config] chroot is disabled.
    2009-05-09 13:38:38.807 [INFO] old priority: 19, new priority: -19
    2009-05-09 13:38:38.807 [INFO] [config:server:basic] For better obscurity, server version number is hidden in the response header.
    2009-05-09 13:38:38.808 [WARN] [config:server:listener] No listener is available for normal virtual host!
    2009-05-09 13:38:38.808 [NOTICE] The maximum number of file descriptor limit is set to 6000.
    2009-05-09 13:38:38.810 [NOTICE] [config:server:epsr:lsphp5]'Process Limit' probably is too low, adjust the limit to: 310.
    2009-05-09 13:38:38.810 [NOTICE] [config:server:epsr:lsphp4]'Process Limit' probably is too low, adjust the limit to: 310.
    2009-05-09 13:38:38.820 [INFO] Processing config file: /usr/local/apache/conf/includes/pre_main_global.conf
    2009-05-09 13:38:38.820 [INFO] Processing config file: /usr/local/apache/conf/includes/pre_main_2.conf
    2009-05-09 13:38:38.820 [INFO] Processing config file: /usr/local/apache/conf/php.conf
    2009-05-09 13:38:38.820 [INFO] Processing config file: /usr/local/apache/conf/mod_bandwidth.conf
    2009-05-09 13:38:38.820 [INFO] Processing config file: /usr/local/apache/conf/modsec2.conf
    2009-05-09 13:38:38.820 [INFO] Processing config file: /usr/local/apache/conf/modsec2.user.conf
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [ERROR] [config] \: pre-mature end of line.
    2009-05-09 13:38:38.821 [INFO] Processing config file: /usr/local/apache/conf/includes/errordocument.conf
    2009-05-09 13:38:38.825 [INFO] Processing config file: /usr/local/apache/conf/includes/pre_virtualhost_global.conf
    2009-05-09 13:38:38.825 [INFO] Processing config file: /usr/local/apache/conf/includes/pre_virtualhost_global.conf
    2009-05-09 13:38:38.825 [INFO] Processing config file: /usr/local/apache/conf/includes/pre_virtualhost_2.conf
    2009-05-09 13:38:38.825 [INFO] Processing config file: /usr/local/apache/conf/includes/pre_virtualhost_2.conf
    2009-05-09 13:38:39.077 [INFO] Processing config file: /usr/local/apache/conf/includes/post_virtualhost_global.conf
    2009-05-09 13:38:39.077 [INFO] Processing config file: /usr/local/apache/conf/includes/post_virtualhost_global.conf
    2009-05-09 13:38:39.077 [INFO] Processing config file: /usr/local/apache/conf/includes/post_virtualhost_2.conf
    2009-05-09 13:38:39.077 [INFO] Processing config file: /usr/local/apache/conf/includes/post_virtualhost_2.conf
    ============================

    I could see the pre-mature errors were generating because it wasn't being able to interpret the modsec rules, so I tried to remove modsec rules and found no more errors in the error log, but litespeed is still not working. Any suggestion would be appreciable.

    Thanks
  2. mistwang

    mistwang LiteSpeed Staff

    How long have you been using the trial key? If you have used the trial key 30 days again on the same server, it wont allow you to use it even you get a new trial key.
  3. hadrick

    hadrick New Member

    No, this was the first try.
  4. mistwang

    mistwang LiteSpeed Staff

    Please PM the IP of your server. we will check if the trial has been blocked because it has been over 30 days since the first try.
  5. hadrick

    hadrick New Member

    Just sent you the IP, please reply early, I need to test to check before purchasing to see how better it perform on my busy server.

Share This Page