LiteSpeed on FreeBSD 6.1

Discussion in 'Install/Configuration' started by Shelby, Aug 5, 2006.

  1. Shelby

    Shelby New Member

    Hello - I installed LiteSpeed on an OS X box yesterday with no problem. However, today, I tried to install it on a FreeBSD 6.1 box that will be my main server. This is the message I got at the end of the install process:

    /usr/libexec/ld-elf.so.1: Shared object "libcrypt.so.2" not found, required by "lshttpd"
    [ERROR] Failed to start lshttpd!

    I did some looking around the web and found references to problems with LiteSpeed and FreeBSD 6. I read that some soft links can solve some problems, but that ssl is not working. SSL will be a requirement for me. Can someone fill me in on the status of LiteSpeed and FreeBSD 6?

    Thanks
    Shelby Westman
  2. mistwang

    mistwang LiteSpeed Staff

  3. amcd

    amcd New Member

    is there any update on this?

    i installed the file referenced above on a quad opteron server but i get this error

    ELF interpreter /libexec/ld-elf32.so.1 not found
    Abort trap
    [ERROR] Failed to start lshttpd!

    [ERROR] Failed to start the web server. For trouble shooting information,
    please refer to documents in "/usr/local/lsws/docs/".




    p.s.: the url in the post above is wrong. you missed the 'std' in between
    Last edited: Aug 23, 2006
  4. mistwang

    mistwang LiteSpeed Staff

  5. amcd

    amcd New Member

    ok, let me try that. it is a totally fresh server so it doesnt matter if i trash it, except that the host will be very angry if i ask for an OS reload

    btw, can u not provide a 64 bit binary?
  6. mistwang

    mistwang LiteSpeed Staff

    We plan to build 64 bit binary, probably for the Enterprise Edition only. :)
  7. thierrypoitras

    thierrypoitras New Member

    Is latest 2.2 now availbale for freebsd 6.1?

    It's misleading. Your minimum requirements ask for freebsd 4.5+. I have freebsd 6.1 now freshly installed and I learn that I can't use lsws2.2? This is bad.

    Do you a plan to provide the latest version for that OS anytime soon?
  8. mistwang

    mistwang LiteSpeed Staff

  9. thierrypoitras

    thierrypoitras New Member

    Last edited: Sep 21, 2006
  10. mistwang

    mistwang LiteSpeed Staff

    Sorry, my bad. Glad you figured it out. :)

Share This Page