Litespeed stops working

Discussion in 'Java JSP/Servlet' started by nicksnels, Jun 12, 2007.

  1. nicksnels

    nicksnels New Member

    I'm trying to get JWChat to work behind Litespeed. I have it deployed on a Tomcat server. JWChat is working when I access it on port 8080. I have also enabled port 8009 on Tomcat.

    On Litespeed (I'm using 2.2.6) I have added an external application:
    Name: Tomcat 5.5
    Type: Servlet Engine
    Address: localhost:8009
    Max Connections: 100
    Initial Request Timeout: 60
    Retry Timeout: 10
    Response Buffering: No

    And I also added a script handler:
    Suffixes: jsp
    Handler Type: Servlet Engine
    Handler Name: Tomcat 5.5

    At this stage I can still gracefully restart Litespeed and it comes back up.

    After that I created a new virtual host based on the centralConfigLog template. On the context menu I added a new context (and deleted the cgi-bin one):

    Type: Java Web App
    URI: /jwchat/
    Servlet Engine: Tomcat 5.5

    If I do a graceful restart, the server doesn't come back up again. I need to delete all entries in httpd_config.xml that point to this new virtual host, before Litespeed starts again. I can't find any errors in stderr.log. I have no more clues of what is going wrong. I'm hoping you can help me. Thanks.

    Kind regards,

    Nick
  2. mistwang

    mistwang LiteSpeed Staff

    It is time to upgrade to 3.1.1 release. :)
  3. nicksnels

    nicksnels New Member

    Thanks for the tip. I upgraded to 3.1.1, but the same thing happens as with the 2.2.6 version. And as an added bonus the new admin console is very slow. What am I doing wrong?
  4. mistwang

    mistwang LiteSpeed Staff

    Please do "strace ./lshttpd -d", and send the output to bug ((a)) litespeedtech ((.)) com, if you do not want to post it here. Please check if there is core files produced in /tmp/lshttpd or lsws/bin directory.

    The YUI used in the new admin console has a slow start.
  5. nicksnels

    nicksnels New Member

    I have send a strace output to you guys. Hope it helps to clarify my problem. Thanks.
  6. mistwang

    mistwang LiteSpeed Staff

    The strace ouptut shows that the LSWS started successfully. Was the vhost causing problem taken out from httpd_config.xml when you run the strace?
    Please remove those core files under /tmp/lshttpd, then try to reproduce the problem, if a new core file is created, email the core, along with lsws/logs/error.log
  7. nicksnels

    nicksnels New Member

    Managed to easily reproduce the error :) I send a new strace file, along with the core file and the error.log file. Hope it provides some clues.
  8. mistwang

    mistwang LiteSpeed Staff

    Found the problem, you need to set "location" to where the java web application located when you define the "/jwchat/" context.
  9. nicksnels

    nicksnels New Member

    I finally got it :) The location in the context tab was set wrongly. Thank you very much for your help. Really helpful and as a plus I have upgraded to the latest and greatest Litespeed version.

    One final question about the admin interface. I'm getting load times of more than 15 seconds (even up to 30 seconds) for every page I access. The load times stay that high even when I access a page I have visited before. The old admin console (2.2.6) was much snappier, with load times no more than 3 seconds. Is there something I can do to speed it up, because this way there is no joy in using the admin console. All I'm doing now is wait, wait and wait even more.
  10. mistwang

    mistwang LiteSpeed Staff

    What kind of server and browser are you using? How many vhosts do you have there?
    The YUI lib used is a bit slow but it should not take that long.
  11. nicksnels

    nicksnels New Member

    Just tested it in IE7. In IE7 it is very fast. My default browser is Firefox 2.0.0.1 and in Firefox it is very slow. So I guess I'll have to use IE7 from now on.
  12. ts77

    ts77 New Member

    Just check your cache-settings in Firefox.
    I've heard of that behaviour if the cache was disabled.

Share This Page